ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jose Alberto Fernandez <JFernan...@viquity.com>
Subject RE: Urgent help with Javac task
Date Thu, 06 Jul 2000 20:08:09 GMT
OK, here is my assesment of the situation with javac and JDK 1.3:

If I set "classic", ant will use JDK 1.2 rules for compiling. Which means
that certain bugs present in the 1.2 compiler will show up. Foe example the
analysis on final instance variable initialization in constructors has bugs
in it, and the same happens in 1.3 when using "classic" option. 

If I set "modern" the compiler will go and parse the classes without
informing of problems, but no output will be generated. In other words ant's
modern compile seem to be broken. Although it is implemented.

I had to go and install jikes to be able to get a compilation going. This
worked, but I do not think I can conviced poeple here that they need to
install a different compiler just to get ant to work correctly.

Finally, does any one know the reason why ant's binaries do not ship with
its own copies of JAXP binaries in its lib directory? I see no reason why we
need to go to javasoft and download JAXP and pollute our classpath. Notice
that we do not need to pollute it for ANT, but just for JAXP. Is there any
issue on shipping binaries for JAXP?

Thanks in advance,

Jose Alberto 

-----Original Message-----
From: Peter Donald [mailto:donaldp@mad.scientist.com]
Sent: Friday, June 30, 2000 5:49 PM
To: ant-dev@jakarta.apache.org
Subject: RE: Urgent help with Javac task


At 04:43  30/6/00 -0700, you wrote:
>I've just started using Ant (and am new to this list). I tried the "modern"
>option and found the same thing. When I looked in the Ant source, I saw
that
>this option is not actually implemented (it does nothing).

Ug - you are using source code from a while back (maybe 2 months ???) and
if you want to download the newest code (which is highly recomended) goto
http://jakarta.apache.org/builds/tomcat/nightly

At 04:24  30/6/00 -0700, you wrote:
>I sent a message a few days ago, but I got no response. I hope I have
better
>luck this time.
>
>I really want to use Ant on a project I am working on, which requires the
>compiler of JDK 1.3 due to bugs in the 1.2.x compilers.

As I said then it works fine with the 1.3 version I have from sun and I
believe I have tried the 1.3 ibm linux version aswell (thou not sure). So
try going back to a stable 1.3 and not a beta. Alternatively you can type

./build.bat -version

if this brings up an error you downloaded an old version of ant and should
download it from site above. Otherwise try sending verbose output (ie with
-verbose flag to list. Then we may be able to help you but as it stands now
you haven't given us remotely enough information to work with :P



Cheers,

Pete

*------------------------------------------------------*
| "Nearly all men can stand adversity, but if you want |
| to test a man's character, give him power."          |
|       -Abraham Lincoln                               |
*------------------------------------------------------*

Mime
View raw message