ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gustavo Romero <grom...@linux.vnet.ibm.com>
Subject OpenJDK 9 support
Date Wed, 14 Jun 2017 15:00:51 GMT
Hi,

I'm trying to run Ambari with OpenJDK 9 and I've got an error regarding the new modules system:

# ambari-server start
Using python  /usr/bin/python
Starting ambari-server
Ambari Server running with administrator privileges.
Organizing resource files at /var/lib/ambari-server/resources...
Ambari database consistency check started...
Server PID at: /var/run/ambari-server/ambari-server.pid
Server out at: /var/log/ambari-server/ambari-server.out
Server log at: /var/log/ambari-server/ambari-server.log
Waiting for server start.........Unable to determine server PID. Retrying...
......Unable to determine server PID. Retrying...
......Unable to determine server PID. Retrying...
ERROR: Exiting with exit code -1.
REASON: Ambari Server java process died with exitcode 1. Check /var/log/ambari-server/ambari-server.out
for more information.

/var/log/ambari-server/ambari-server.out file shows:

Caused by: java.lang.reflect.InaccessibleObjectException: Unable to make protected final java.lang.Class
java.lang.ClassLoader.defineClass(java.lang.String,byte[],int,int,java.security.ProtectionDomain)
throws java.lang.ClassFormatError accessible: module java.base does not "opens java.lang"
to unnamed
module @381cad29
       at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:337)
       at java.base/java.lang.reflect.AccessibleObject.checkCanSetAccessible(AccessibleObject.java:281)
       at java.base/java.lang.reflect.Method.checkCanSetAccessible(Method.java:197)
       at java.base/java.lang.reflect.Method.setAccessible(Method.java:191)
       at com.google.inject.internal.cglib.core.$ReflectUtils$2.run(ReflectUtils.java:56)
       at java.base/java.security.AccessController.doPrivileged(Native Method)
       at com.google.inject.internal.cglib.core.$ReflectUtils.<clinit>(ReflectUtils.java:46)

Is there any upstream fix for that issue or an open ticket for that? I could not find one
search for "ambari jdk9" on JIRA.

Thank you.

Best regards,
Gustavo


Mime
View raw message