ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kartik Mathur <kar...@bluedata.com>
Subject Re: Unable to delete host from ambari using API (HDP2.4 with Ambari 2.2)
Date Fri, 16 Sep 2016 18:52:59 GMT
Hi Sumit thanks for replying , I stopped ambari-agent on the host and
restarted ambari server now I am getting host not found from UI as well as
from the api , however I can still see the host on ambari UI.

This is the message from ambari UI

404 status codereceived on DELETE method for API:
/api/v1/clusters/h2/hosts/bluedata-68.bdlocal

*Error message: *Not Found

On Fri, Sep 16, 2016 at 8:44 AM, Sumit Mohanty <smohanty@hortonworks.com>
wrote:

> ​Have you stopped the agent running on the host? If not then it will
> re-register.
>
>
> After stopping the agent, delete the host from api/v1/hosts/<hostname> as
> well.
> ------------------------------
> *From:* Kartik Mathur <kartik@bluedata.com>
> *Sent:* Thursday, September 15, 2016 11:43 PM
> *To:* user@ambari.apache.org
> *Subject:* Unable to delete host from ambari using API (HDP2.4 with
> Ambari 2.2)
>
>
> I have 7 nodes HDP 2.4 with ambari 2.2 cluster -
>
>
> This is the closest document that I am able to find for deleting host
> using APIs.
>
> My host has these services running -
>
> 1) Zookeeper_server
>
> 2)DATANODE
>
> 3)NODEMANAGER
>
> 4)RegionServer
>
> 5)FLUME
>
> 1) I first decommision data and node manager using this -
>
> curl -u admin:admin -i -H 'X-Requested-By: ambari' -X POST -d '{
> "RequestInfo":{ "context":"Decommission DataNode",
> "command":"DECOMMISSION", "parameters":{ "slave_type":"DATANODE",
> "excluded_hosts":"bluedata-69.bdlocal" }, "operation_level":{
> "level":"HOST_COMPONENT", "cluster_name":"h2" } },
> "Requests/resource_filters":[ { "service_name":"HDFS",
> "component_name":"NAMENODE" } ] }' http://10.35.229.2:8080/
> api/v1/clusters/h2/requests
>
> 2)Next I stop and delete all components (listed above, which I am
> successfully able to)
>
> 3) Strange thing happens after this -
>
> There is a random behavior on ambari UI where we sometimes see this host
> and sometimes not , besides now if I try to delete host from ambari API it
> gives me server error and tells host does not exist!! , however I can still
> go on UI and delete the host.
>
> All I wanted to do is decommision data node and delete a host in a clean
> way using ambari APIs , please assist
> Thanks
> Kartik
>

Mime
View raw message