ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amanda Moran <amanda.mo...@esgyn.com>
Subject Re: Build Error
Date Mon, 08 Aug 2016 17:56:23 GMT
Hi there Bosco-

I tried this out on Centos 6.7. I did this to install docker:

Edit /etc/yum.repos.d/docker-main.repo :

[docker-main-repo]
name=Docker main Repository
baseurl=https://yum.dockerproject.org/repo/main/centos/$releasever
enabled=1
gpgcheck=1
gpgkey=https://yum.dockerproject.org/gpg

Install docker: yum install docker-engine
Start docker daemon: service docker start

I then followed your steps exactly.

I got this error:
Step 8 : ADD
https://www.apache.org/dist/maven/maven-3/3.3.9/binaries/apache-maven-3.3.9-bin.tar.gz.md5
/tools
Downloading [==================================================>]     32
B/32 B
stat
/var/lib/docker/devicemapper/mnt/2ffd5d75bab0324b15b8410254a9677673489a01d5204f1db8b75ccab0c4206c/rootfs/tools/tmp:
not a directory
+ docker run --rm -it -v /home/centos/ambari:/ambari -w /ambari -v
/home/centos/.m2:/home/build/.m2 --user build ambari_dev mvn -B clean
install package -DskipTests '-Dpython.ver=python\>=2.6' -Preplaceurl
Unable to find image 'ambari_dev:latest' locally
Pulling repository ambari_dev
Error: image library/ambari_dev:latest not found


I just wanted to test this out for you since I was curious. Don't worry
about debugging this for my use especially if centos 6.7 isn't supported.

Thanks!

Amanda


On Sun, Aug 7, 2016 at 7:36 PM, Don Bosco Durai <bosco@apache.org> wrote:

> Thanks for trying it out. It seems there is a permission issue when the
> mvn build from the Docker container is accessing your mounted file system.
>
>
>
> Can you try this?
>
>
>
> Login as yourself (or build user)
>
> cd $HOME
>
> sudo rm -rf .m2/repository
>
> tar xfz <ambari src tar file>
>
> cd <ambari source folder>
>
> wget https://issues.apache.org/jira/secure/attachment/
> 12822494/build_ambari_using_docker.sh
>
> chmod a+x build_ambari_using_docker.sh
>
> ./build_ambari_using_docker.sh -build_image
>
> or
>
> sudo ./build_ambari_using_docker.sh -build_image
>
>
>
>
>
> Can someone who has Docker, please try it out and let me know it works for
> you? I have tested the below steps in my Ubuntu host and a fresh AWS EC2
> environment and it worked.
>
> 1. If not docker is not installed, please install docker
>
> 2. sudo usermod -a -G docker $USER
>
> 3. Close terminal and open a new terminal
>
> 4. Make sure "id" has group "docker" in the list
>
> 5. cd $AMBARI_GIT_SRC_FOLDER or cd $HOME; git clone git://
> git.apache.org/ambari.git; cd ambari
>
> 5. git checkout trunk
>
> 6. git pull
>
> 7. wget https://issues.apache.org/jira/secure/attachment/
> 12822494/build_ambari_using_docker.sh
>
> 8. chmod a+x build_ambari_using_docker.sh
>
> 9. ./build_ambari_using_docker.sh
>
>
>
> Please let me know your host OS…
>
>
>
> Thanks
>
>
>
> Bosco
>
>
>
>
>
>
>
> *From: *Ascot Moss <ascot.moss@gmail.com>
> *Reply-To: *<user@ambari.apache.org>
> *Date: *Sunday, August 7, 2016 at 6:35 AM
>
> *To: *<user@ambari.apache.org>
> *Subject: *Re: Build Error
>
>
>
> and tried the following:
>
>
> (run as root)
>
>
>
> docker rmi ambari_dev
>
> /build_ambari_using_docker.sh
>
> [INFO] Rat check: Summary of files. Unapproved: 0 unknown: 0 generated: 0
> approved: 1274 licence.
>
> [INFO]
>
> [INFO] --- maven-assembly-plugin:2.2-beta-5:single (make-assembly) @
> ambari ---
>
> [INFO] Reading assembly descriptor: /ambari/ambari-project/src/
> main/assemblies/empty.xml
>
> [INFO]
>
> [INFO] --- maven-install-plugin:2.4:install (default-install) @ ambari ---
>
> [INFO] Installing /ambari/pom.xml to /home/build/.m2/repository/
> org/apache/ambari/ambari/2.2.2.0.0/ambari-2.2.2.0.0.pom
>
> [INFO] ------------------------------------------------------------
> ------------
>
> [INFO] Reactor Summary:
>
> [INFO]
>
> [INFO] Ambari Main ........................................ FAILURE [
> 1.722 s]
>
> [INFO] Apache Ambari Project POM .......................... SKIPPED
>
> [INFO] Ambari Web ......................................... SKIPPED
>
> [INFO] Ambari Views ....................................... SKIPPED
>
> [INFO] Ambari Admin View .................................. SKIPPED
>
> [INFO] ambari-metrics ..................................... SKIPPED
>
> [INFO] Ambari Metrics Common .............................. SKIPPED
>
> [INFO] Ambari Metrics Hadoop Sink ......................... SKIPPED
>
> [INFO] Ambari Metrics Flume Sink .......................... SKIPPED
>
> [INFO] Ambari Metrics Kafka Sink .......................... SKIPPED
>
> [INFO] Ambari Metrics Storm Sink .......................... SKIPPED
>
> [INFO] Ambari Metrics Collector ........................... SKIPPED
>
> [INFO] Ambari Metrics Monitor ............................. SKIPPED
>
> [INFO] Ambari Metrics Grafana ............................. SKIPPED
>
> [INFO] Ambari Metrics Assembly ............................ SKIPPED
>
> [INFO] Ambari Server ...................................... SKIPPED
>
> [INFO] Ambari Agent ....................................... SKIPPED
>
> [INFO] Ambari Client ...................................... SKIPPED
>
> [INFO] Ambari Python Client ............................... SKIPPED
>
> [INFO] Ambari Groovy Client ............................... SKIPPED
>
> [INFO] Ambari Shell ....................................... SKIPPED
>
> [INFO] Ambari Python Shell ................................ SKIPPED
>
> [INFO] Ambari Groovy Shell ................................ SKIPPED
>
> [INFO] ------------------------------------------------------------
> ------------
>
> [INFO] BUILD FAILURE
>
> [INFO] ------------------------------------------------------------
> ------------
>
> [INFO] Total time: 2.071 s
>
> [INFO] Finished at: 2016-08-07T13:33:26+00:00
>
> [INFO] Final Memory: 28M/702M
>
> [INFO] ------------------------------------------------------------
> ------------
>
> [ERROR] Failed to execute goal org.apache.maven.plugins:
> maven-install-plugin:2.4:install (default-install) on project ambari:
> Failed to install artifact org.apache.ambari:ambari:pom:2.2.2.0.0:
> /home/build/.m2/repository/org/apache/ambari/ambari/2.2.2.0.0/ambari-2.2.2.0.0.pom
> (Permission denied) -> [Help 1]
>
> [ERROR]
>
> [ERROR] To see the full stack trace of the errors, re-run Maven with the
> -e switch.
>
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>
> [ERROR]
>
> [ERROR] For more information about the errors and possible solutions,
> please read the following articles:
>
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/
> MojoExecutionException
>
>
>
>
>
> as already run as root, not sure why still got
>  /home/build/.m2/repository/org/apache/ambari/ambari/2.2.2.0.0/ambari-2.2.2.0.0.pom
> (Permission denied)
>
>
>
>
>
>
>
>
>
> On Sun, Aug 7, 2016 at 9:22 PM, Ascot Moss <ascot.moss@gmail.com> wrote:
>
> HI,
>
> Tried again.
>
>
>
> Added:
> echo $MAVEN_HOME
>
> /opt/apache-maven-3.3.9
>
>
>
>
>
> (command)
>
> mvn -B -e clean install package -DskipTests=true
>
>
>
> (log)
>
> npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
>
> npm WARN notsup Not compatible with your operating system or architecture:
> fsevents@0.2.1
>
> npm WARN Ambari@2.1.3 No license field.
>
> [INFO]
>
> [INFO] --- exec-maven-plugin:1.2.1:exec (compile-brunch) @ ambari-web ---
>
> /usr/lib/node_modules/brunch/lib/watch.js:433
>
>             throw new Error("You probably need to execute `npm install` to
> install brunch plugins. " + error);
>
>             ^
>
>
>
> Error: You probably need to execute `npm install` to install brunch
> plugins. SyntaxError: Setter must have exactly one formal parameter.
>
>   at /usr/lib/node_modules/brunch/lib/watch.js:433:19
>
>   at Array.map (native)
>
>   at loadDeps (/usr/lib/node_modules/brunch/lib/watch.js:418:10)
>
>   at loadPackages (/usr/lib/node_modules/brunch/lib/watch.js:438:15)
>
>   at /usr/lib/node_modules/brunch/lib/watch.js:458:19
>
>   at /usr/lib/node_modules/brunch/lib/helpers.js:529:16
>
>   at /usr/lib/node_modules/brunch/lib/helpers.js:485:14
>
>   at /usr/lib/node_modules/brunch/node_modules/read-components/
> index.js:263:16
>
>   at /usr/lib/node_modules/brunch/node_modules/read-components/
> index.js:72:14
>
>   at FSReqWrap.cb [as oncomplete] (fs.js:257:19)
>
>
>
> [INFO] ------------------------------------------------------------
> ------------
>
> [INFO] Reactor Summary:
>
> [INFO]
>
> [INFO] Ambari Main ........................................ SUCCESS [
> 2.577 s]
>
> [INFO] Apache Ambari Project POM .......................... SUCCESS [
> 0.036 s]
>
> [INFO] Ambari Web ......................................... FAILURE [
> 22.124 s]
>
> [INFO] Ambari Views ....................................... SKIPPED
>
> [INFO] Ambari Admin View .................................. SKIPPED
>
> [INFO] ambari-metrics ..................................... SKIPPED
>
> [INFO] Ambari Metrics Common .............................. SKIPPED
>
> [INFO] Ambari Metrics Hadoop Sink ......................... SKIPPED
>
> [INFO] Ambari Metrics Flume Sink .......................... SKIPPED
>
> [INFO] Ambari Metrics Kafka Sink .......................... SKIPPED
>
> [INFO] Ambari Metrics Storm Sink .......................... SKIPPED
>
> [INFO] Ambari Metrics Collector ........................... SKIPPED
>
> [INFO] Ambari Metrics Monitor ............................. SKIPPED
>
> [INFO] Ambari Metrics Grafana ............................. SKIPPED
>
> [INFO] Ambari Metrics Assembly ............................ SKIPPED
>
> [INFO] Ambari Server ...................................... SKIPPED
>
> [INFO] Ambari Agent ....................................... SKIPPED
>
> [INFO] Ambari Client ...................................... SKIPPED
>
> [INFO] Ambari Python Client ............................... SKIPPED
>
> [INFO] Ambari Groovy Client ............................... SKIPPED
>
> [INFO] Ambari Shell ....................................... SKIPPED
>
> [INFO] Ambari Python Shell ................................ SKIPPED
>
> [INFO] Ambari Groovy Shell ................................ SKIPPED
>
> [INFO] ------------------------------------------------------------
> ------------
>
> [INFO] BUILD FAILURE
>
> [INFO] ------------------------------------------------------------
> ------------
>
> [INFO] Total time: 25.063 s
>
> [INFO] Finished at: 2016-08-07T21:13:30+08:00
>
> [INFO] Final Memory: 32M/991M
>
> [INFO] ------------------------------------------------------------
> ------------
>
> [ERROR] Failed to execute goal org.codehaus.mojo:exec-maven-plugin:1.2.1:exec
> (compile-brunch) on project ambari-web: Command execution failed. Process
> exited with an error: 1 (Exit value: 1) -> [Help 1]
>
> org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute
> goal org.codehaus.mojo:exec-maven-plugin:1.2.1:exec (compile-brunch) on
> project ambari-web: Command execution failed.
>
> at org.apache.maven.lifecycle.internal.MojoExecutor.execute(
> MojoExecutor.java:212)
>
> at org.apache.maven.lifecycle.internal.MojoExecutor.execute(
> MojoExecutor.java:153)
>
> at org.apache.maven.lifecycle.internal.MojoExecutor.execute(
> MojoExecutor.java:145)
>
> at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.
> buildProject(LifecycleModuleBuilder.java:116)
>
> at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.
> buildProject(LifecycleModuleBuilder.java:80)
>
> at org.apache.maven.lifecycle.internal.builder.singlethreaded.
> SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
>
> at org.apache.maven.lifecycle.internal.LifecycleStarter.
> execute(LifecycleStarter.java:128)
>
> at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
>
> at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
>
> at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
>
> at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
>
> at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)
>
> at org.apache.maven.cli.MavenCli.main(MavenCli.java:199)
>
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>
> at sun.reflect.NativeMethodAccessorImpl.invoke(
> NativeMethodAccessorImpl.java:62)
>
> at sun.reflect.DelegatingMethodAccessorImpl.invoke(
> DelegatingMethodAccessorImpl.java:43)
>
> at java.lang.reflect.Method.invoke(Method.java:498)
>
> at org.codehaus.plexus.classworlds.launcher.Launcher.
> launchEnhanced(Launcher.java:289)
>
> at org.codehaus.plexus.classworlds.launcher.Launcher.
> launch(Launcher.java:229)
>
> at org.codehaus.plexus.classworlds.launcher.Launcher.
> mainWithExitCode(Launcher.java:415)
>
> at org.codehaus.plexus.classworlds.launcher.Launcher.
> main(Launcher.java:356)
>
> Caused by: org.apache.maven.plugin.MojoExecutionException: Command
> execution failed.
>
> at org.codehaus.mojo.exec.ExecMojo.execute(ExecMojo.java:362)
>
> at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(
> DefaultBuildPluginManager.java:134)
>
> at org.apache.maven.lifecycle.internal.MojoExecutor.execute(
> MojoExecutor.java:207)
>
> ... 20 more
>
> Caused by: org.apache.commons.exec.ExecuteException: Process exited with
> an error: 1 (Exit value: 1)
>
> at org.apache.commons.exec.DefaultExecutor.executeInternal(
> DefaultExecutor.java:377)
>
> at org.apache.commons.exec.DefaultExecutor.execute(
> DefaultExecutor.java:160)
>
> at org.codehaus.mojo.exec.ExecMojo.executeCommandLine(ExecMojo.java:610)
>
> at org.codehaus.mojo.exec.ExecMojo.execute(ExecMojo.java:352)
>
> ... 22 more
>
> [ERROR]
>
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>
> [ERROR]
>
> [ERROR] For more information about the errors and possible solutions,
> please read the following articles:
>
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/
> MojoExecutionException
>
> [ERROR]
>
> [ERROR] After correcting the problems, you can resume the build with the
> command
>
> [ERROR]   mvn <goals> -rf :ambari-web
>
>
>
>
>
>
>
> On Mon, Aug 1, 2016 at 11:21 PM, Amanda Moran <amanda.moran@esgyn.com>
> wrote:
>
> Sorry if you already answered this.
>
>
>
> Is maven in your path?
>
>
>
> Thanks.
>
>
> On Aug 1, 2016, at 7:18 AM, Ascot Moss <ascot.moss@gmail.com> wrote:
>
> HI,
>
>
>
> Still have compilation error:
>
> sudo yum install -y python-setuptools
>
> sudo pip install psutil
>
> *sudo npm install -g brunch@1.7.20*
>
> *sudo pip install psutil*
>
> *mvn -B -e clean install package rpm:rpm -Dbuild-rpm -Dpython.ver='python
> >= 2.6' *
>
> [INFO] RPM build errors:
>
> [INFO] ------------------------------------------------------------
> ------------
>
> [INFO] Reactor Summary:
>
> [INFO]
>
> [INFO] Ambari Main ........................................ SUCCESS [
> 3.305 s]
>
> [INFO] Apache Ambari Project POM .......................... SUCCESS [
> 0.489 s]
>
> [INFO] Ambari Web ......................................... SUCCESS
> [04:30 min]
>
> [INFO] Ambari Views ....................................... SUCCESS [
> 1.530 s]
>
> [INFO] Ambari Admin View .................................. SUCCESS [
> 17.835 s]
>
> [INFO] ambari-metrics ..................................... SUCCESS [
> 1.036 s]
>
> [INFO] Ambari Metrics Common .............................. SUCCESS [
> 1.104 s]
>
> [INFO] Ambari Metrics Hadoop Sink ......................... SUCCESS [
> 1.936 s]
>
> [INFO] Ambari Metrics Flume Sink .......................... SUCCESS [
> 1.398 s]
>
> [INFO] Ambari Metrics Kafka Sink .......................... SUCCESS [
> 0.990 s]
>
> [INFO] Ambari Metrics Storm Sink .......................... SUCCESS [
> 2.385 s]
>
> [INFO] Ambari Metrics Collector ........................... SUCCESS [01:41
> min]
>
> [INFO] Ambari Metrics Monitor ............................. SUCCESS [
> 1.501 s]
>
> [INFO] Ambari Metrics Grafana ............................. SUCCESS [
> 15.498 s]
>
> [INFO] Ambari Metrics Assembly ............................ SUCCESS [04:55
> min]
>
> [INFO] Ambari Server ...................................... SUCCESS
> [33:51 min]
>
> [INFO] Ambari Agent ....................................... SUCCESS [
> 32.124 s]
>
> [INFO] Ambari Client ...................................... SUCCESS [
> 15.318 s]
>
> [INFO] Ambari Python Client ............................... FAILURE [
> 13.884 s]
>
> [INFO] Ambari Groovy Client ............................... SKIPPED
>
> [INFO] Ambari Shell ....................................... SKIPPED
>
> [INFO] Ambari Python Shell ................................ SKIPPED
>
> [INFO] Ambari Groovy Shell ................................ SKIPPED
>
> [INFO] ------------------------------------------------------------
> ------------
>
> [INFO] BUILD FAILURE
>
> [INFO] ------------------------------------------------------------
> ------------
>
> [INFO] Total time: 46:49 min
>
> [INFO] Finished at: 2016-08-01T16:32:25+08:00
>
> [INFO] Final Memory: 325M/2743M
>
> [INFO] ------------------------------------------------------------
> ------------
>
> [ERROR] Failed to execute goal org.codehaus.mojo:rpm-maven-plugin:2.1-alpha-2:rpm
> (default-cli) on project python-client: RPM build execution returned: '1'
> executing '/bin/sh -c cd /usr/local/apache-ambari-2.2.
> 2-src/ambari-client/python-client/target/rpm/python-client/SPECS &&
> rpmbuild -bb --buildroot /usr/local/apache-ambari-2.2.
> 2-src/ambari-client/python-client/target/rpm/python-client/buildroot
> --define '_topdir /usr/local/apache-ambari-2.2.2-src/ambari-client/python-
> client/target/rpm/python-client' --target x86_64-redhat-linux
> python-client.spec' -> [Help 1]
>
> org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute
> goal org.codehaus.mojo:rpm-maven-plugin:2.1-alpha-2:rpm (default-cli) on
> project python-client: RPM build execution returned: '1' executing '/bin/sh
> -c cd /usr/local/apache-ambari-2.2.2-src/ambari-client/python-
> client/target/rpm/python-client/SPECS && rpmbuild -bb --buildroot
> /usr/local/apache-ambari-2.2.2-src/ambari-client/python-
> client/target/rpm/python-client/buildroot --define '_topdir
> /usr/local/apache-ambari-2.2.2-src/ambari-client/python-
> client/target/rpm/python-client' --target x86_64-redhat-linux
> python-client.spec'
>
>         at org.apache.maven.lifecycle.internal.MojoExecutor.execute(
> MojoExecutor.java:212)
>
>         at org.apache.maven.lifecycle.internal.MojoExecutor.execute(
> MojoExecutor.java:153)
>
>         at org.apache.maven.lifecycle.internal.MojoExecutor.execute(
> MojoExecutor.java:145)
>
>         at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.
> buildProject(LifecycleModuleBuilder.java:116)
>
>         at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.
> buildProject(LifecycleModuleBuilder.java:80)
>
>         at org.apache.maven.lifecycle.internal.builder.singlethreaded.
> SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
>
>         at org.apache.maven.lifecycle.internal.LifecycleStarter.
> execute(LifecycleStarter.java:128)
>
>         at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
>
>         at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
>
>         at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
>
>         at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
>
>         at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)
>
>         at org.apache.maven.cli.MavenCli.main(MavenCli.java:199)
>
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>
>         at sun.reflect.NativeMethodAccessorImpl.invoke(
> NativeMethodAccessorImpl.java:62)
>
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(
> DelegatingMethodAccessorImpl.java:43)
>
>         at java.lang.reflect.Method.invoke(Method.java:498)
>
>         at org.codehaus.plexus.classworlds.launcher.Launcher.
> launchEnhanced(Launcher.java:289)
>
>         at org.codehaus.plexus.classworlds.launcher.Launcher.
> launch(Launcher.java:229)
>
>         at org.codehaus.plexus.classworlds.launcher.Launcher.
> mainWithExitCode(Launcher.java:415)
>
>         at org.codehaus.plexus.classworlds.launcher.Launcher.
> main(Launcher.java:356)
>
> Caused by: org.apache.maven.plugin.MojoExecutionException: RPM build
> execution returned: '1' executing '/bin/sh -c cd
> /usr/local/apache-ambari-2.2.2-src/ambari-client/python-
> client/target/rpm/python-client/SPECS && rpmbuild -bb --buildroot
> /usr/local/apache-ambari-2.2.2-src/ambari-client/python-
> client/target/rpm/python-client/buildroot --define '_topdir
> /usr/local/apache-ambari-2.2.2-src/ambari-client/python-
> client/target/rpm/python-client' --target x86_64-redhat-linux
> python-client.spec'
>
>         at org.codehaus.mojo.rpm.RPMHelper.buildPackage(
> RPMHelper.java:150)
>
>         at org.codehaus.mojo.rpm.AbstractRPMMojo.execute(
> AbstractRPMMojo.java:792)
>
>         at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(
> DefaultBuildPluginManager.java:134)
>
>         at org.apache.maven.lifecycle.internal.MojoExecutor.execute(
> MojoExecutor.java:207)
>
>         ... 20 more
>
> [ERROR]
>
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>
> [ERROR]
>
> [ERROR] For more information about the errors and possible solutions,
> please read the following articles:
>
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/
> MojoExecutionException
>
> [ERROR]
>
> [ERROR] After correcting the problems, you can resume the build with the
> command
>
> [ERROR]   mvn <goals> -rf :python-client
>
>
>
> On Sat, Jul 30, 2016 at 3:35 PM, Don Bosco Durai <bosco@apache.org> wrote:
>
> I was able to reproduce your issue. It seems, the build user I am creating
> didn’t have the permission to write to the local folder. I have updated the
> script to create the build user with the same UID from the host user. I
> have also using CentOS 6 image to build (as per the documentation).
>
>
>
> I have updated the JIRA with the updated script.
> https://issues.apache.org/jira/browse/AMBARI-17944
>
>
>
> Please do the following:
>
>
>
> 1.       docker rmi ambari_dev
>
> 2.       Go to root folder of your Ambari source
>
> 3.       $YOUR_PATH/build_ambari_using_docker.sh
>
>
>
> Let me know how it goes.
>
>
>
> Thanks
>
>
>
> Bosco
>
>
>
>
>
>
>
>
>
> *From: *Ascot Moss <ascot.moss@gmail.com>
> *Reply-To: *<user@ambari.apache.org>
> *Date: *Thursday, July 28, 2016 at 4:11 PM
> *To: *<user@ambari.apache.org>
> *Subject: *Re: Build Error
>
>
>
> Hi,
>
> yum install -y python-setuptools
>
> Loaded plugins: fastestmirror
>
> Loading mirror speeds from cached hostfile
>
>  * base: mirror.vpshosting.com.hk
>
>  * epel: ftp.cuhk.edu.hk
>
>  * extras: mirror.vpshosting.com.hk
>
>  * updates: mirror.vpshosting.com.hk
>
> Package python-setuptools-0.9.8-4.el7.noarch already installed and latest
> version
>
> Nothing to do
>
>
>
>
>
> "My script should have done the complete build. What is the error you are
> getting?"
>
> The error as follows:
>
> [INFO] ------------------------------------------------------------
> ------------
>
> [INFO] Reactor Summary:
>
> [INFO]
>
> [INFO] Ambari Main ........................................ FAILURE [
> 2.135 s]
>
> [INFO] Apache Ambari Project POM .......................... SKIPPED
>
> [INFO] Ambari Web ......................................... SKIPPED
>
> [INFO] Ambari Views ....................................... SKIPPED
>
> [INFO] Ambari Admin View .................................. SKIPPED
>
> [INFO] ambari-metrics ..................................... SKIPPED
>
> [INFO] Ambari Metrics Common .............................. SKIPPED
>
> [INFO] Ambari Metrics Hadoop Sink ......................... SKIPPED
>
> [INFO] Ambari Metrics Flume Sink .......................... SKIPPED
>
> [INFO] Ambari Metrics Kafka Sink .......................... SKIPPED
>
> [INFO] Ambari Metrics Storm Sink .......................... SKIPPED
>
> [INFO] Ambari Metrics Collector ........................... SKIPPED
>
> [INFO] Ambari Metrics Monitor ............................. SKIPPED
>
> [INFO] Ambari Metrics Grafana ............................. SKIPPED
>
> [INFO] Ambari Metrics Assembly ............................ SKIPPED
>
> [INFO] Ambari Server ...................................... SKIPPED
>
> [INFO] Ambari Agent ....................................... SKIPPED
>
> [INFO] Ambari Client ...................................... SKIPPED
>
> [INFO] Ambari Python Client ............................... SKIPPED
>
> [INFO] Ambari Groovy Client ............................... SKIPPED
>
> [INFO] Ambari Shell ....................................... SKIPPED
>
> [INFO] Ambari Python Shell ................................ SKIPPED
>
> [INFO] Ambari Groovy Shell ................................ SKIPPED
>
> [INFO] ------------------------------------------------------------
> ------------
>
> [INFO] BUILD FAILURE
>
> [INFO] ------------------------------------------------------------
> ------------
>
> [INFO] Total time: 3.035 s
>
> [INFO] Finished at: 2016-07-28T23:09:34+00:00
>
> [INFO] Final Memory: 17M/479M
>
> [INFO] ------------------------------------------------------------
> ------------
>
> [ERROR] Failed to execute goal org.apache.rat:apache-rat-plugin:0.11:check
> (default) on project ambari: Could not create report parent directory
> /ambari/target -> [Help 1]
>
> [ERROR]
>
> [ERROR] To see the full stack trace of the errors, re-run Maven with the
> -e switch.
>
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>
> [ERROR]
>
> [ERROR] For more information about the errors and possible solutions,
> please read the following articles
>
>
>
>
>
>
>
>
>
>
>
>
>
> On Fri, Jul 29, 2016 at 12:49 AM, Don Bosco Durai <bosco@apache.org>
> wrote:
>
> > Step 1: run your script
>
> > [INFO] Ambari Main ........................................ FAILURE [
> 0.521 s]
>
> My script should have done the complete build. What is the error you are
> getting?
>
>
>
> > Is "mvn clean install package -DskipTests"  correct command to build
> Ambari?
>
> Depends what do you want to do? For released versions, Apache Ambari
> already gives you the final binary bits, including RPM. So shouldn’t be
> needing to build.
>
>
>
> (From your very recent build)…
>
> > mvn -B -e clean install package rpm:rpm -Dbuild-rpm
> -Dpython.ver='python >= 2.6' –DskipTests
>
> If you are compiling outside Docker, then try installing “yum install -y
> python-setuptools”. My script might not be able to take the space in the
> “python >= 2.6”. But if you want, I can look into it.
>
>
>
> Thanks
>
>
>
> Bosco
>
>
>
>
>
>
>
>
>
>
>
>
>



-- 
Thanks,

Amanda Moran

Mime
View raw message