ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Zang <rz...@hortonworks.com>
Subject Re: localization with Ambari
Date Thu, 07 Jul 2016 18:39:51 GMT
Hi Yan,

Texts for NameNode and SNameNode are not coming from i18n file. Please double check if you
modified anything in master_component.hbs.

    <td {{bindAttr class=":summary-label comp.summaryLabelClassName"}}>
      <a href="#" {{action showDetails comp.host}} title="{{unbound comp.host.publicHostName}}"
rel="UsageTooltip">
        {{#if comp.displayNameAdvanced}}
          {{comp.displayNameAdvanced}}
        {{else}}
          {{comp.displayName}}
        {{/if}}
      </a>
    </td>

Richard

From: 刘岩 <liuyan@richinfo.cn<mailto:liuyan@richinfo.cn>>
Reply-To: "user@ambari.apache.org<mailto:user@ambari.apache.org>" <user@ambari.apache.org<mailto:user@ambari.apache.org>>
Date: Sunday, July 3, 2016 at 9:49 AM
To: user <user@ambari.apache.org<mailto:user@ambari.apache.org>>
Subject: localization with Ambari



Hi  All


 i have recently doing some translations with the ambari UI ,  and i found a tricky bug that
whenever that i modified the Em.I18n.translations part in the app.js ,  my UI looked like
this


[cid:25788630543596504]


the  namenode and secondary namenode  is missing.   and it's same for all other services pages.
 everything that labled with a green correction mark will not show up as desired .


ambari version 2.2.1.0


does anyone knows why?


thank you very much

Yan Liu

Richinfo

04/07/2016






Mime
View raw message