ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pawel Akonom <pawel.ako...@vnomic.com>
Subject Grafana service can't start because of missing config file
Date Wed, 15 Jun 2016 19:48:57 GMT
Hi,


I am trying to install HDP stack version 2.3.4.7 using ambari version 2.2.2.0.


After Hadoop cluster installation metrics are missing because grafana service can't be started.


[root@hdp-vora-slave ~]# tail  /var/lib/ambari-agent/data/output-76.txt
2016-06-15 14:52:27,237 - Changing permission for /etc/ambari-metrics-grafana/conf/ams-grafana.ini
from 644 to 600
2016-06-15 14:52:27,237 - Execute[('chown', '-R', 'ams', '/etc/ambari-metrics-grafana/conf')]
{'sudo': True}
2016-06-15 14:52:27,245 - Execute[('chown', '-R', 'ams', '/var/log/ambari-metrics-grafana')]
{'sudo': True}
2016-06-15 14:52:27,250 - Execute[('chown', '-R', 'ams', '/var/lib/ambari-metrics-grafana')]
{'sudo': True}
2016-06-15 14:52:27,260 - Execute[('chown', '-R', 'ams', '/var/run/ambari-metrics-grafana')]
{'sudo': True}
2016-06-15 14:52:27,272 - Execute['/usr/sbin/ambari-metrics-grafana start'] {'user': 'ams'}
2016-06-15 14:52:28,332 - Checking if AMS Grafana datasource already exists
2016-06-15 14:52:28,332 - Connecting (GET) to hdp-vora-slave.virtunomic.com:3000/api/datasources
Command aborted. Server considered task failed and automatically aborted it


"/usr/sbin/ambari-metrics-grafana start" is executing following command to start grafana service:


nohup /usr/lib/ambari-metrics-grafana/bin/grafana-server --pidfile=/var/run/ambari-metrics-grafana/grafana-server.pid
--config=/etc/ambari-metrics-grafana/conf/ams-grafana.ini cfg:default.paths.data=/var/lib/ambari-metrics-grafana
cfg:default.paths.logs=/var/log/ambari-metrics-grafana


When I run the command manually I get error:


[ams@hdp-vora-slave ~]$ /usr/lib/ambari-metrics-grafana/bin/grafana-server --pidfile=/var/run/ambari-metrics-grafana/grafana-server.pid
--config=/etc/ambari-metrics-grafana/conf/ams-grafana.ini cfg:default.paths.data=/var/lib/ambari-metrics-grafana
cfg:default.paths.logs=/var/log/ambari-metrics-grafana
2016/06/15 15:36:30 [log.go:75 Fatal()] [E] Failed to parse defaults.ini, open /home/ams/conf/defaults.ini:
no such file or directory


Grafana config file is missing:


[ams@hdp-vora-slave ~]$ ls -la /home/ams/conf/defaults.ini
ls: cannot access /home/ams/conf/defaults.ini: No such file or directory


Do you know the problem? How it can be solved?

Br,
Pawel

Mime
View raw message