ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Zhang <zjf...@gmail.com>
Subject Re: Issues when using blueprint
Date Wed, 25 May 2016 03:05:46 GMT
It doesn't work even I specify it as HDP 2.4, any clues ?


[root@jzhang-test3-1 ~]# curl -X PUT  -u admin:admin -d @repo.json -H
'X-Requested-By: ambari'
http://jzhang-test3-1.opentacklocal:8080/api/v1/stacks/HDP/versions/2.4/operating_systems/centos6/repositories/HDP
{
  "status" : 404,
  "message" :
"org.apache.ambari.server.controller.spi.NoSuchResourceException: The
specified resource doesn't exist: Stack data, stackName=HDP,
stackVersion=2.4, osType=centos6, repoId=HDP"
}


On Wed, May 25, 2016 at 12:11 AM, Sean Roberts <sroberts@hortonworks.com>
wrote:

> That’s correct. HDP 2.5 is not ready, but the stack version is listed in
> the Ambari directories. For now, please use 2.4 for now.
>
>
>
> *From:* Andrew Stadtler [mailto:andy@phdata.io]
> *Sent:* Tuesday, May 24, 2016 4:03 PM
> *To:* user@ambari.apache.org
> *Cc:* Alejandro Fernandez <afernandez@hortonworks.com>
> *Subject:* Re: Issues when using blueprint
>
>
>
> I don’t think HDP 2.5 is publicly available yet.
>
>
>
> stackVersion=2.5
>
>
>
> On May 24, 2016, at 2:49 AM, Jeff Zhang <zjffdu@gmail.com> wrote:
>
>
>
> Thanks, Alejandro, but after I use HDP as repoId, it still fails.  (Do I
> use wrong stackVersion/osType ? I don't find valid
> stackVersoin/osType/repoId list in
> https://cwiki.apache.org/confluence/display/AMBARI/Blueprints)
>
>
>
>
>
>
>
> [root@jzhang-test3-1 ~]# curl -X PUT  -u admin:admin -d @repo.json -H
> 'X-Requested-By: ambari'
> http://jzhang-test3-1.openstacklocal:8080/api/v1/stacks/HDP/versions/2.5/operating_systems/centos6/repositories/HDP
>
> {
>
>   "status" : 404,
>
>   "message" :
> "org.apache.ambari.server.controller.spi.NoSuchResourceException: The
> specified resource doesn't exist: Stack data, stackName=HDP,
> stackVersion=2.5, osType=centos6, repoId=HDP"
>
>
>
> On Sat, May 21, 2016 at 2:22 AM, Alejandro Fernandez <
> afernandez@hortonworks.com> wrote:
>
> Hi Jeff,
>
>
>
> Valid repo names are "HDP" or "HDP-UTILS" instead of "hw_repo".
>
>
>
> Thanks,
>
> Alejandro
>
>
>
> *From: *Jeff Zhang <zjffdu@gmail.com>
> *Reply-To: *"user@ambari.apache.org" <user@ambari.apache.org>
> *Date: *Thursday, May 19, 2016 at 11:23 PM
> *To: *"user@ambari.apache.org" <user@ambari.apache.org>
> *Subject: *Issues when using blueprint
>
>
>
> I try to use blueprints,  but fails with 2 problems.
>
> One is when setup repo, another is when registering blueprint. Here’s the
> errors I get
>
>
>
> *Setup repo.*
>
> curl -X PUT  -u admin:admin -d @repo.json -H 'X-Requested-By: ambari'
> http://jzhang-test3-1.openstacklocal:8080/api/v1/stacks/HDP/versions/2.5/operating_systems/centos6/repositories/hw_repo
>
>
>
> Error I get:
>
> {
>
>   "status" : 404,
>
>   "message" :
> "org.apache.ambari.server.controller.spi.NoSuchResourceException: The
> specified resource doesn't exist: Stack data, stackName=HDP,
> stackVersion=2.5, osType=centos6, repoId=hw_repo”
>
> }
>
>
>
> *Register blueprint*
>
>
>
> curl -X POST -u admin:admin -d @dev_cluster.json -H 'X-Requested-By:
> ambari'
> http://jzhang-test3-1.openstacklocal:8080/api/v1/blueprints/dev_cluster
>
>
>
> Error I get
>
> {
>
>   "status" : 400,
>
>   "message" : "Blueprint configuration validation failed: Missing required
> properties.  Specify a value for these properties in the blueprint
> configuration. {host_group_1={kerberos-env=[kdc_type, kdc_hosts,
> encryption_types, realm, ldap_url, container_dn]}}”
>
> }
>
>
>
> Attach are the request body file for these 2 cases.
>
>
>
> --
>
> Best Regards
>
> Jeff Zhang
>
>
>
>
>
> --
>
> Best Regards
>
> Jeff Zhang
>
>
>



-- 
Best Regards

Jeff Zhang

Mime
View raw message