ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Jackson <jackson.christopher....@gmail.com>
Subject Re: How to determine stack version with qualifier
Date Mon, 11 Jan 2016 18:52:40 GMT
Disregard, it seems what I wanted was:

default("/hostLevelParams/stack_version", None)

Regards,
Christopher Jackson

> On Jan 11, 2016, at 1:37 PM, Christopher Jackson <jackson.christopher.lee@gmail.com>
wrote:
> 
> During customer service install It’s important for me to know exactly which stack I’m
working with. For instance I have the following environment:
> 
> pwd
> /var/lib/ambari-server/resources/stacks/HDP
> ls
> 2.0  2.0.6  2.0.6.GlusterFS  2.1  2.1.GlusterFS  2.2  2.3  2.3.GlusterFS
> 
> How can i tell if I’m using 2.3.GlusterFS or 2.3 stack? The following commands only
reported the numeric version and not the GlusterFS qualifier.
> 
> stack_name = default("/hostLevelParams/stack_name", None).lower()  (this returned: ‘hdp’)
> stack_version = default("/commandParams/version", None) (this returned: 2.3.4.0-3485)
> 
> To be exact is there an Ambari function or property that will tell me I’m using the
2.3.GlusterFS stack version?
> 
> Regards,
> 
> Christopher Jackson
> 
> 
> 


Mime
View raw message