ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roberto Bentivoglio <roberto.bentivog...@radicalbit.io>
Subject Re: Error trying to install Ambari on RHEL 7.2 EC2 instance
Date Fri, 18 Dec 2015 10:02:36 GMT
Hi Everyone,

a little update: we've successfully installed ambari-server from the
repository also on an updated CentOS 7.2.
The distro details are:
CentOS Linux release 7.2.1511 (Core)
NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"

The issue seems related to RHEL 7.2 or EC2.

Thanks,
Roberto

2015-12-18 10:43 GMT+01:00 Roberto Bentivoglio <
roberto.bentivoglio@radicalbit.io>:

> Hi Everyone,
>
> I'm having troubles trying to install Ambari on an EC2 Amazon instance.
> The version of the OS is the following:
>
> NAME="Red Hat Enterprise Linux Server"
> VERSION="7.2 (Maipo)"
> ID="rhel"
> ID_LIKE="fedora"
> VERSION_ID="7.2"
> PRETTY_NAME="Red Hat Enterprise Linux Server 7.2 (Maipo)"
>
> First I've updated the distro using the following command:
> sudo yum update
>
> After that I've added the repository in this way:
> sudo wget -nv
> http://public-repo-1.hortonworks.com/ambari/centos7/2.x/updates/2.1.2.1/ambari.repo
> -O /etc/yum.repos.d/ambari.repo
>
> Finally I've run
> sudo yum install ambari-server
>
> Yum tries to install the following Ambari release:
> ambari-server | x86_64 | 2.1.2.1-418 | Updates-ambari-2.1.2.1
>
> I'm getting the following error:
> Downloading packages:
> ambari-server-2.1.2.1-418.x86_64.rpm  | 385 MB  00:00:08
> Running transaction check
> Running transaction test
> Transaction test succeeded
> Running transaction
>   Installing : ambari-server-2.1.2.1-418.x86_64   1/1
> Error unpacking rpm package ambari-server-2.1.2.1-418.x86_64
> error: unpacking of archive failed: cpio: mkdir Verifying  :
> ambari-server-2.1.2.1-418.x86_64   1/1
>
> Failed:
>   ambari-server.x86_64 0:2.1.2.1-418
>
> Complete!
>
> I've tried to install the package cpio and also a rpm built directly from
> the sources but I'm getting the same error.
> Please note that both the procedures have been completed successfully on a
> CentOS 6.x box.
>
> Does anybody have some idea about the resolution of this error?
>
> Many thanks in advance!
>
> Regards,
> Roberto Bentivoglio
>
>

Mime
View raw message