ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Artem Ervits <artemerv...@gmail.com>
Subject Re: Issue while upgrading Ambari from 1.6.1 to 2.1.2
Date Wed, 16 Dec 2015 12:55:10 GMT
Try upgrading to 1.7 first. 1.6 is an old release. Then go to 2.1.2.1.
On Dec 16, 2015 7:43 AM, "Deepak Sharma" <deepakmca05@gmail.com> wrote:

> Hi
> I upgraded Ambari server and agents on the cluster from 1.6.1 to 2.1.2
> The upgrade went fine.
> I can see that 2.1.2 is the version now.
> But while performing the ambari server schema upgrade  , its failing.
>
> 16 Dec 2015 17:13:32,028  INFO [main] ControllerModule:187 - Detected
> POSTGRES as the database type from the JDBC URL
> 16 Dec 2015 17:13:33,607  INFO [main] ControllerModule:564 - Binding and
> registering notification dispatcher class
> org.apache.ambari.server.notifications.dispatchers.EmailDispatcher
> 16 Dec 2015 17:13:33,609  INFO [main] ControllerModule:564 - Binding and
> registering notification dispatcher class
> org.apache.ambari.server.notifications.dispatchers.AlertScriptDispatcher
> 16 Dec 2015 17:13:33,681  INFO [main] ControllerModule:564 - Binding and
> registering notification dispatcher class
> org.apache.ambari.server.notifications.dispatchers.SNMPDispatcher
> 16 Dec 2015 17:13:38,096  INFO [main] SchemaUpgradeHelper:280 - Upgrading
> schema to target version = 2.1.2.1
> 16 Dec 2015 17:13:38,120  INFO [main] SchemaUpgradeHelper:289 - Upgrading
> schema from source version = 1.6.1
> 16 Dec 2015 17:13:38,122  INFO [main] SchemaUpgradeHelper:150 - Upgrade
> path: [{ upgradeCatalog: sourceVersion = 1.6.1, targetVersion = 1.7.0 }, {
> upgradeCatalog: sourceVersion = 1.7.0, targetVersion = 2.0.0 }, {
> upgradeCatalog: sourceVersion = 2.0.0, targetVersion = 2.1.0 }, {
> upgradeCatalog: sourceVersion = 2.1.0, targetVersion = 2.1.1 }, {
> upgradeCatalog: sourceVersion = 2.1.1, targetVersion = 2.1.2 }, {
> upgradeCatalog: sourceVersion = 2.1.2, targetVersion = 2.1.2.1 }, {
> upgradeCatalog: sourceVersion = null, targetVersion = 2.1.2 }]
> 16 Dec 2015 17:13:38,122  INFO [main] SchemaUpgradeHelper:188 - Executing
> DDL upgrade...
> 16 Dec 2015 17:13:38,131  INFO [main] DBAccessorImpl:718 - Executing
> query: ALTER TABLE ambari_sequences RENAME COLUMN "value" to sequence_value
> 16 Dec 2015 17:13:38,136 ERROR [main] DBAccessorImpl:724 - Error executing
> query: ALTER TABLE ambari_sequences RENAME COLUMN "value" to sequence_value
> org.postgresql.util.PSQLException: ERROR: must be owner of relation
> ambari_sequences
>
> Caused by: org.postgresql.util.PSQLException: ERROR: must be owner of
> relation ambari_sequences
>
> I am really stuck here.
> Did anyone faced the same issue ? If yes , what is the resolution.
> Else please help me with the steps to downgrade it back to 1.6.1
> I am running this ambari on SLES 11.
>
>
> --
> Thanks
> Deepak
>

Mime
View raw message