ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Zhang <zjf...@gmail.com>
Subject Re: Ambari fails to start
Date Sat, 26 Dec 2015 14:57:43 GMT
Thanks Myroslav, it works.



On Sat, Dec 26, 2015 at 3:18 PM, Myroslav Papyrkovskyy <
mpapyrkovskyy@hortonworks.com> wrote:

> Hello Jeff. As I see you have exception related to existing database from
> previous version.
> This is because when you removed 2.0 data folder of PostgreSQL was not
> affected and still contains data from 2.0.
> Usually you can run
> # ambari-server reset
> this will drop database related to Ambari and recreate it from scratch.
> Please, note that all data will be lost (but I think you are ok with this,
> as only way to keep data is to follow normal upgrade).
>
> Regards,
> Myroslav
>
> 26 груд. 2015 р. о 08:16 Jeff Zhang <zjffdu@gmail.com> написав(ла):
>
> Hi Sumit,
>
> Is there any document about how to clean ambari cleanly. I follow the
> instruction here, but still see the issue.
>
> http://mapredit.blogspot.com/2014/06/remove-hdp-and-ambari-completely.html
>
> On Sat, Dec 26, 2015 at 1:22 PM, Sumit Mohanty <smohanty@hortonworks.com>
> wrote:
>
>> That is not supported in the sense that DB will not be auto-upgraded to
>> 2.2.
>>
>>
>> You probably have to uninstall Ambari and clean various "ambari-server"
>> folders and then fresh install 2.2. This of course means that all 2.0 data
>> in the Ambari DB is lost.
>> ------------------------------
>> *From:* Jeff Zhang <zjffdu@gmail.com>
>> *Sent:* Friday, December 25, 2015 9:07 PM
>>
>> *To:* user@ambari.apache.org
>> *Subject:* Re: Ambari fails to start
>>
>> Actually I didn't follow the normal instruction. I just remove the 2.0
>> using yum and install 2.2 again. maybe this cause this issue.
>>
>> On Sat, Dec 26, 2015 at 12:43 PM, Sumit Mohanty <smohanty@hortonworks.com
>> > wrote:
>>
>>> ​Do you have the URL used to deploy the 2.0.x version?
>>>
>>>
>>> Did "ambari-server upgrade" command show any other error?
>>> ------------------------------
>>> *From:* Jeff Zhang <zjffdu@gmail.com>
>>> *Sent:* Friday, December 25, 2015 8:18 PM
>>> *To:* user@ambari.apache.org
>>> *Subject:* Re: Ambari fails to start
>>>
>>> from 2.0 to 2.2
>>>
>>> On Sat, Dec 26, 2015 at 12:15 PM, Sumit Mohanty <
>>> smohanty@hortonworks.com> wrote:
>>>
>>>> ​What version you are upgrading from and to?
>>>> ------------------------------
>>>> *From:* Jeff Zhang <zjffdu@gmail.com>
>>>> *Sent:* Friday, December 25, 2015 7:02 PM
>>>> *To:* user@ambari.apache.org
>>>> *Subject:* Ambari fails to start
>>>>
>>>>
>>>> I meet the following error when upgrading ambari, could anyone help ?
>>>>
>>>> 26 Dec 2015 10:57:46,911 ERROR [main] AmbariServer:819 - Failed to run
>>>> the Ambari Server
>>>> com.google.inject.ProvisionException: Guice provision errors:
>>>>
>>>> 1) Error injecting method, Exception [EclipseLink-4011] (Eclipse
>>>> Persistence Services - 2.5.2.v20140319-9ad6abd):
>>>> org.eclipse.persistence.exceptions.DatabaseException
>>>> Exception Description: Error preallocating sequence numbers.  The
>>>> sequence table information is not complete.
>>>>   at
>>>> org.apache.ambari.server.api.services.AmbariMetaInfo.init(AmbariMetaInfo.java:243)
>>>>   at
>>>> org.apache.ambari.server.api.services.AmbariMetaInfo.class(AmbariMetaInfo.java:125)
>>>>   while locating org.apache.ambari.server.api.services.AmbariMetaInfo
>>>>     for field at
>>>> org.apache.ambari.server.controller.AmbariServer.ambariMetaInfo(AmbariServer.java:145)
>>>>   at
>>>> org.apache.ambari.server.controller.AmbariServer.class(AmbariServer.java:145)
>>>>   while locating org.apache.ambari.server.controller.AmbariServer
>>>>
>>>> 1 error
>>>>         at
>>>> com.google.inject.internal.InjectorImpl$4.get(InjectorImpl.java:987)
>>>>         at
>>>> com.google.inject.internal.InjectorImpl.getInstance(InjectorImpl.java:1013)
>>>>         at
>>>> org.apache.ambari.server.controller.AmbariServer.main(AmbariServer.java:812)
>>>> Caused by: Exception [EclipseLink-4011] (Eclipse Persistence Services -
>>>> 2.5.2.v20140319-9ad6abd):
>>>> org.eclipse.persistence.exceptions.DatabaseException
>>>> Exception Description: Error preallocating sequence numbers.  The
>>>> sequence table information is not complete.
>>>>
>>>> --
>>>> Best Regards
>>>>
>>>> Jeff Zhang
>>>>
>>>
>>>
>>>
>>> --
>>> Best Regards
>>>
>>> Jeff Zhang
>>>
>>
>>
>>
>> --
>> Best Regards
>>
>> Jeff Zhang
>>
>
>
>
> --
> Best Regards
>
> Jeff Zhang
>
>
>


-- 
Best Regards

Jeff Zhang

Mime
View raw message