ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eirik Thorsnes <eirik.thors...@uni.no>
Subject Re: Ambari metrics collector dies in 2.1.3-snapshot
Date Fri, 04 Dec 2015 08:31:10 GMT
On 03.12.15 19:31, Dmitry Sen wrote:
> As a workaround for already deployed cluster, you can set
> java.library.path option to /usr/hdp/2.3.4.0-3371/hadoop/lib/native/
> in ams-hbase-env config

Hi,

As mentioned, I've already checked that the java.library.path contains 
the hadoop native libraries, same as you listed (coming from my build of 
AMS). Also, I've tried to replace that folder with a  symlink that 
points to the main hadoop lib/native location from the HDP installation. 
Both gives the same failure.

I've also checked that the process that is started has the 
java.library.path on the command-line according to ps output.

Could it be that AMS now has dependencies to newer versions of 
Hadoop/YARN? I'm on HDP 2.3.0.0, I see you have 2.3.4.0 in the path 
example above.

Note also that this is built and run on Java 8u66, could that be 
related? (Though that was true also for my previous test of 2.1.2-snap 
that worked).

Regards,
Eirik

Mime
View raw message