ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sumit Mohanty <smoha...@hortonworks.com>
Subject Re: Ambari installation problem on EC2 RHEL 7.2 instance
Date Tue, 22 Dec 2015 15:00:31 GMT
?Do you see anything in yum.log or /var/log/messages that are related to this? Perhaps you
can try verbose installation to see what the error is.

________________________________
From: Mauro Cortellazzi <mao.corte@gmail.com>
Sent: Tuesday, December 22, 2015 6:55 AM
To: user@ambari.apache.org
Subject: Ambari installation problem on EC2 RHEL 7.2 instance

Hello Everyone,

I'm having troubles in trying to install Ambari on an EC2 Amazon instance.
The OS version is the following:

NAME="Red Hat Enterprise Linux Server"
VERSION="7.2 (Maipo)"
ID="rhel"
ID_LIKE="fedora"
VERSION_ID="7.2"
PRETTY_NAME="Red Hat Enterprise Linux Server 7.2 (Maipo)"

First I've added the repository as mentioned into documentation by the command:
sudo wget -nv http://public-repo-1.hortonworks.com/ambari/centos7/2.x/updates/2.1.2.1/ambari.repo
-O /etc/yum.repos.d/ambari.repo

Then I've tried to install Ambari Server via yum:
sudo yum install ambari-server

with the following output:
Yum tries to install the following Ambari release:
ambari-server | x86_64 | 2.1.2.1-418 | Updates-ambari-2.1.2.1

I'm getting the following error:
Downloading packages:
ambari-server-2.1.2.1-418.x86_64.rpm  | 385 MB  00:00:08
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : ambari-server-2.1.2.1-418.x86_64   1/1
Error unpacking rpm package ambari-server-2.1.2.1-418.x86_64
error: unpacking of archive failed: cpio: mkdir Verifying  :
ambari-server-2.1.2.1-418.x86_64   1/1

Failed:
  ambari-server.x86_64 0:2.1.2.1-418

Complete!

So I've tried to update the distro with:
sudo yum update
but I had the same result as the installation process via Yum

So I had built the rpm package directly from source code but I'm getting the same error.

The same procedures (installation from repo and from sources) works properly on a Centos 7.X
and Centos 6.X.

Has Someone have any idea about how to solve this problem?

Thank you!
Bests.
Mauro Cortellazzi

Mime
View raw message