ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Boesch <java...@gmail.com>
Subject Host substitution not happening within blueprint
Date Thu, 15 Oct 2015 17:52:51 GMT
Summary: the HOST_GROUP .. <group_name> is not being substituted within the
blueprint. I am wondering why and what the correct process would be.


Details:

We see the following template substitution error (i.e. it is not performed)
in NameNode logs - which shows the blueprints are not setup/working
correctly:

2015-10-13 17:58:49,101 INFO  namenode.NameNode
(NameNode.java:setClientNamenodeAddress(397)) - fs.defaultFS is
*hdfs://%HOSTGROUP::nn_1%:8020*
2015-10-13 17:58:49,103 ERROR namenode.NameNode (NameNode.java:main(1571))
- Failed to start namenode.
java.lang.IllegalArgumentException: Malformed escape pair at index 7:
hdfs://%HOSTGROUP::nn_1%:8020



Here is the first portion of our blueprints:


{

  "configurations" : [

    {

      "core-site" : {

        "properties_attributes" : {

          "final" : {

            "fs.defaultFS" : "true",

             "ha.zookeeper.quorum" :
"%HOSTGROUP::slave_zkfc%:2181,%HOSTGROUP::slave_zk%:2181"

          }

        },

        "properties" : {

          "fs.defaultFS" : *"hdfs://%HOSTGROUP::nn_1%:8020",*

          "fs.trash.interval" : "360",


Here is the  hostgroup called nn_1

  "host_groups" : [

    {

      "name" : "nn_1",

      "configurations" : [ ],

      "components" : [

        {

          "name" : "NAMENODE"

        },

        {

          "name" : "HDFS_CLIENT"

        },

 .. etc

      ],

      "cardinality" : "1"

    },

So why is the substitution not occurring? Thx!

Mime
View raw message