ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim To <...@phemi.com>
Subject Re: Ambari metrics collector CPU usage
Date Fri, 18 Sep 2015 16:59:46 GMT
Thanks for the tip Alen. It turned out we have the same problem on one of
our servers and your tip fixed it so thanks a lot. Would this be considered
an ambari bug ? I would think  so since it slowed our server down so much
that it starts to affect other services that were running it. Has anyone
raised a ticket with Horton Works to fix this?

Tim

On Thu, Sep 17, 2015 at 8:06 AM, Alen Williams <Alen.Williams@telus.com>
wrote:

> Hi Andrew.
>
> We were seeing exactly the same thing. On a 32 core machine all of the
> cores would regularly sit around 75-80% cpu utilization.
>
> The only thing that alleviated it was to change the operations mode to
> distributed. As soon as that happened the CPU utilization dropped to very
> little, the occasional spike being the extend of it.
>
> Alen.
>
>
> http://docs.hortonworks.com/HDPDocuments/Ambari-2.1.0.0/bk_ambari_reference_guide/content/_configuring_ambari_metrics_for_distributed_mode.html
>
> -----Original Message-----
> From: Andrew Robertson [mailto:andyrobertson101@gmail.com]
> Sent: September 16, 2015 10:35 PM
> To: user@ambari.apache.org
> Subject: Ambari metrics collector CPU usage
>
> How much CPU is the ambari metrics collector expected to use (Ambari
> 2.1.1)?
>
> In my production cluster with 12 machines the ams hbase master process has
> averaged 82% of a cpu core (sandybridge), based on total cpu usage in
> seconds over the past 2 weeks. A test cluster with 4 machines has also been
> behaving the same way with very high cpu on the ams hbase master java
> process. I'm not sure if this is the new normal for metrics (versus the
> negligible overhead with gmon/gmetad) or if there's something wrong
> somewhere in either ams, hbase, or in the
> (default) config.
>
> Are others seeing high CPU here as well?
>
> Is there something I should look at to see what it may be doing, or are
> there suggestions for reducing the cpu usage? Or is this a known issue? I
> looked through the open issues and didn't see anything obvious that was
> tracking this.
>
> Thank you!
>



-- 
*Tim To*
Software Engineer
*PHEMI Health Systems*
180-887 Great Northern Way
Vancouver, BC V5T 4T5
website <http://www.phemi.com/> twitter <https://twitter.com/PHEMISystems>
Linkedin
<http://www.linkedin.com/company/3561810?trk=tyah&trkInfo=tarId%3A1403279580554%2Ctas%3Aphemi%20hea%2Cidx%3A1-1-1>

Mime
View raw message