ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konrad Hübner <konrad.hueb...@gmail.com>
Subject Fwd: Issue with deploying Cluster through Ambari Agent behind proxy
Date Thu, 20 Aug 2015 07:20:04 GMT
Hi,

I try to deploy a HDP 2.3 Cluster with Ambari 2.1. By force I am behind a
proxy server. The proxy is configured both systemwide in /etc/env,
including export of environment variables for sudoers and in
/etc/apt/apt.conf.d with Accquire::proxy command. Ambari Server was
configured to use a non-root users with sudo privilege. Installing ambari
client worked, but when starting the deployment of the cluster through the
agent, the agent runs apt-get install and that failes when resolving the
hostname. This looks like it is not using the proxy. Please find the log
output below. Any help is appreciated!

Thanks
-Konrad

2015-08-20 06:53:13,299 - Package['unzip'] {}
2015-08-20 06:53:13,310 - Installing package unzip ('/usr/bin/apt-get
-q -o Dpkg::Options::=--force-confdef --allow-unauthenticated
--assume-yes install unzip')
2015-08-20 06:53:13,514 - Execution of '['/usr/bin/apt-get', '-q',
'-o', 'Dpkg::Options::=--force-confdef', '--allow-unauthenticated',
'--assume-yes', 'install', 'unzip']' returned 100. Reading package
lists...
Building dependency tree...
Reading state information...
Suggested packages:
  zip
The following NEW packages will be installed:
  unzip
0 upgraded, 1 newly installed, 0 to remove and 7 not upgraded.
Need to get 157 kB of archives.
After this operation, 391 kB of additional disk space will be used.
Err http://archive.ubuntu.com/ubuntu/ trusty-updates/main unzip amd64
6.0-9ubuntu1.3
  Could not resolve 'archive.ubuntu.com'
Err http://security.ubuntu.com/ubuntu/ trusty-security/main unzip
amd64 6.0-9ubuntu1.3
  Could not resolve 'security.ubuntu.com'
E: Failed to fetch
http://security.ubuntu.com/ubuntu/pool/main/u/unzip/unzip_6.0-9ubuntu1.3_amd64.deb
 Could not resolve 'security.ubuntu.com'

E: Unable to fetch some archives, maybe run apt-get update or try with
--fix-missing?
2015-08-20 06:53:13,514 - Failed to install package unzip. Executing
`/usr/bin/apt-get update -qq`
2015-08-20 06:53:14,780 - Retrying to install package unzip

Mime
View raw message