ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sumit Mohanty <smoha...@hortonworks.com>
Subject Re: Namenode HA setup using blueprint.
Date Sat, 22 Aug 2015 04:09:16 GMT
Blueprint based cluster creation needs two API calls.


curl -u admin:admin -H "X-Requested-By: ambari" -X POST -d @/tmp/bp-1h-2w.json http://localhost:8080/api/v1/blueprints/bp1
This one deploys the blueprint

curl -u admin:admin -H "X-Requested-By: ambari" -X POST -d @/tmp/hg-1h-2w.json http://localhost:8080/api/v1/clusters/c1

This one creates the cluster.

Here is a sample for the second call ...

{
  "blueprint" : "bp1",
  "default_password" : "default",
  "host_groups" :[
    {
      "name" : "host_group_1",
      "hosts" : [
        {
          "fqdn" : "sma-test-1.host.com"
        }
      ]
    },
    {
      "name" : "host_group_2",
      "hosts" : [
        {
          "fqdn" : "sma-test-2.host.com"
        },
        {
          "fqdn" : "sma-test-3.host.com"
        }
      ]
    }
  ]
}

________________________________
From: Anandha L Ranganathan <analog.sony@gmail.com>
Sent: Friday, August 21, 2015 8:52 PM
To: user@ambari.apache.org
Subject: Namenode HA setup using blueprint.



I am trying to setup Namenode HA using blueprint. After I call the API through the curl call
, it says the following message.

anandr-2073$ curl -u admin:xxxxx -H "X-Requested-by:ambari" -i -k -X POST http://localhost:8080/api/v1/blueprints/blueprint-hdfs-ha
-d @blueprint-9-nodes-ha.json
HTTP/1.1 100 Continue
HTTP/1.1 201 Created
Set-Cookie: AMBARISESSIONID=1vr0zdr5fsqtsdoiexk2djzb6;Path=/ Expires: Thu, 01 Jan 1970 00:00:00
GMT Content-Type: text/plain Content-Length: 0 Server: Jetty(7.6.7.v20120910)

But in the cluster , neither do I see changes in the Ambari UI nor Do I see it in the config
files.  What is the issue could be,  and could someone help  ?


Here is my blueprint for Namenode HA

Mime
View raw message