ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Artem Ervits <artemerv...@gmail.com>
Subject Re: Any way to reset Ambari Install Wizard?
Date Tue, 28 Jul 2015 19:48:20 GMT
try to restart ambari server and agents, then stop and start services,
sometimes services need to announce themselves to Ambari that they're
installed. Always refer to the ambari-server log. Worst case scenario,
delete Ambari_metrics service with API and clean up the postgres DB
manually, tables to concentrate on are hostservicedesiredstate,
servicedesiredstate etc. This should be last resort.

On Tue, Jul 28, 2015 at 3:11 PM, Benoit Perroud <benoit@noisette.ch> wrote:

> Some manual update in DB is most likely needed.
>
> *WARNING* use this at your own risk
>
> The table that needs to be updated is cluster_version.
>
> As far as I tested 2.1, it required less manual intervention than 2.0.1.
> Upgrade has a retry button for most of the steps, and this is really cool.
>
> Hope this help.
>
> Benoit
>
>
>
> 2015-07-28 20:01 GMT+02:00 Ken Barclay <kbarclay@ancestry.com>:
>
>>  Hello,
>>
>>  I upgraded a small test cluster from HDP 2.1 to HDP 2.2 and Ambari
>> 2.0.1. In following the steps to replace Nagios + Ganglia with the Ambari
>> Metrics System using the Ambari Wizard, an install failure occurred on one
>> node due to an outdated glibc library. I updated glibc and verified the
>> Metrics packages could be installed, but couldn’t go back and finish the
>> installation through the wizard. The problem is: it flags some of the
>> default settings, saying they need to be changed, but it skips past the
>> screen very quickly that enables those settings to be changed, without
>> allowing anything to be entered. So the button that allows you to proceed
>> with the installation never becomes enabled.
>>
>>  I subsequently manually finished the Metrics installation using the
>> Ambari API and have it running in Distributed mode. But Ambari’s wizard
>> cannot be used for anything now: the same problem described above occurs
>> for every service I try to install.
>>
>>  Can Ambari be reset somehow in this situation, or do I need to
>> reinstall it?
>> Or do you recommend installing 2.1?
>>
>>  Thanks
>> Ken
>>
>
>

Mime
View raw message