ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sumit Mohanty <smoha...@hortonworks.com>
Subject Re: Restart of flume-agents bug
Date Wed, 01 Jul 2015 14:18:05 GMT
?When you start Flume using Ambari - /var/lib/ambari-agent/data folder on the host will have
corresponding command outputs/errors etc. Can you share those?


Feel free to send a direct email as I think Apache email will not let attachments.

________________________________
From: Marco <marco.frg@gmail.com>
Sent: Wednesday, July 01, 2015 7:14 AM
To: user@ambari.apache.org
Subject: Re: Restart of flume-agents bug

I've tried this but do not find any related processes

I've searched via
pgrep -fl flume
pgrep -fl agent1

Also, I've restarted the corresponding server.

If I try to restart the flume agent, I get the same issue :(

I've also tried to delete /var/run/flume and create it again....also no effect.

BR Marco



2015-07-01 15:57 GMT+02:00 Sumit Mohanty <smohanty@hortonworks.com<mailto:smohanty@hortonworks.com>>:

?If flume agents are running then you need to kill those processes as well along with deleting
the pid files.

________________________________
From: Marco <marco.frg@gmail.com<mailto:marco.frg@gmail.com>>
Sent: Wednesday, July 01, 2015 6:42 AM
To: user@ambari.apache.org<mailto:user@ambari.apache.org>
Subject: Restart of flume-agents bug

Hi,

I've troubles when restarting flume agents with ambari.

I've found this jira entry https://issues.apache.org/jira/browse/AMBARI-10657, which describes
my problem (var/run/flume/a2.pid' returned 1.

Since I am using the hortonworks distribution (ambari 2.0.0) I cannot just upgrade/patch...is
there any workaround for this issue? I've tried to delete the pid file but with no effect.

Thanks,
Marco



--
Viele Grüße,
Marco

Mime
View raw message