ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Juanjo Marron <juanjo.mar...@yahoo.com>
Subject Re: Enabling namenode HA fails when non default ports are used
Date Tue, 21 Jul 2015 21:55:18 GMT
Hi again Yusaku,

JIRA AMBARI-12486 have been created related with this bug.

I have spent some time investigating how to solve it. HDFS and Zookeper Port values are actually
harcoded on the step3_controller for HA wizard  (/ambari/ambari-web/app/controllers/main/admin/highAvailability/nameNode/step3_controller.js)
and set on the HA_proprerties.js file.

I'm missing more visibility to understand the global design and I'm not sure how to get current
configuration values (Not just  default ones) since the ports information seems not to be
loaded on content or configs.

Please, can you route the JIRA to the right developer on your team or provide me more details
on how to solve this bug.

Best regards, 
Juanjo 


     On Wednesday, July 8, 2015 4:34 PM, Juanjo Marron <juanjo.marron@yahoo.com> wrote:
   

 Hi Yusaku,

Thanks for your answer.
Yes, I'll create a JIRA for this issue

Regards,

Juanjo 


     On Wednesday, July 8, 2015 4:20 PM, Yusaku Sako <yusaku@hortonworks.com> wrote:
   

 Hi Juanjo,
This is a bug that should be fixed.  Thanks for pointing this out.Would you like to go ahead
and file a JIRA for this?
Thanks,Yusaku
From: Juanjo Marron <juanjo.marron@yahoo.com>
Reply-To: Ambari User <user@ambari.apache.org>, Juanjo Marron <juanjo.marron@yahoo.com>
Date: Thursday, July 2, 2015 11:56 AM
To: Ambari User <user@ambari.apache.org>
Subject: Enabling namenode HA fails when non default ports are used

Hi all,

I have a question related with High Availability configuration when changing default ports

I checked the source code for the Step 3 in namenode HA wizard (ambari-web/app/controllers/main/admin/highAvailability/nameNode/step3_controller.js)

The node address is looked from the configuration but the port is hardcoded ex:
...
this.setConfigInitialValue(config,zooKeeperHosts[0] + ':2181,' + zooKeeperHosts[1] + ':2181,'
+ zooKeeperHosts[2] + ':2181');
...

Is there any reason to not looking actual port number and use the default value?

Thanks for your answer,

Regards,

Juanjo Marron




   

  
Mime
View raw message