ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kristopher Kane <kkane.l...@gmail.com>
Subject 2.0 Blueprints are not setting hadoop.proxyuser.{hive,hcat}.hosts
Date Mon, 11 May 2015 16:29:34 GMT
I have a core-site blueprint:

{ "core-site" : { "properties_attributes" : { "final" : { "fs.defaultFS" : "
true" } }, "properties" : { "fs.defaultFS" : "
hdfs://%HOSTGROUP::host_group_1%:8020", "fs.trash.interval" : "360", "
ha.failover-controller.active-standby-elector.zk.op.retries" : "120", "
hadoop.http.authentication.simple.anonymous.allowed" : "true", "
hadoop.proxyuser.hcat.groups" : "*", "hadoop.proxyuser.hcat.hosts" : "*", "
hadoop.proxyuser.hive.groups" : "*", "hadoop.proxyuser.hive.hosts" : "*", "
hadoop.proxyuser.oozie.groups" : "*", "hadoop.proxyuser.oozie.hosts" : "*",
"hadoop.security.auth_to_local" : "\n DEFAULT", "
hadoop.security.authentication" : "simple", "hadoop.security.authorization"
: "false", "io.compression.codecs" : "
org.apache.hadoop.io.compress.GzipCodec,org.apache.hadoop.io.compress.DefaultCodec,org.apache.hadoop.io.compress.SnappyCodec
", "io.file.buffer.size" : "131072", "io.serializations" : "
org.apache.hadoop.io.serializer.WritableSerialization", "
ipc.client.connect.max.retries" : "50", "ipc.client.connection.maxidletime"
: "30000", "ipc.client.idlethreshold" : "8000", "ipc.server.tcpnodelay" : "
true", "mapreduce.jobtracker.webinterface.trusted" : "false", "
proxyuser_group" : "users" } } }, ..which sets the proxy hosts/groups for
hive and hcat to wildcard, however, when the cluster starts up from a
blueprint install, I see that they are set to the host of the Hive master
services. Sound like a bug? Kris

Mime
View raw message