ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Klinger" ...@web-computing.de>
Subject AW: Ambari 2.0 - Namenode Moved - ConnectionRefused Error
Date Thu, 21 May 2015 14:32:52 GMT
Thanks this was exactly the problem

 

Freundliche Grüße / Kind regards 

Daniel Klinger

 

--

 

Software Engineer

 

Web Computing GmbH

Mendelstraße 11

48149 Münster 

 

Telefon:  +49 251 39655243

E-Mail:     <mailto:dk@web-computing.de> dk@web-computing.de

Web Computing GmbH, Münster

Handelsregister/Commercial Register: Amtsgericht Münster HRB 13758

Geschäftsführung: Sebastian Zimmermann, Maximilian Busch

 

Von: Yusaku Sako [mailto:yusaku@hortonworks.com] 
Gesendet: Dienstag, 19. Mai 2015 06:22
An: user@ambari.apache.org
Betreff: Re: Ambari 2.0 - Namenode Moved - ConnectionRefused Error

 

Hi Daniel,

 

You might need to run Hive Metatool to update the pointer to the new
NameNode: https://cwiki.apache.org/confluence/display/Hive/Hive+MetaTool

 

hive --service metatool -listFSRoot <- shows the current pointer to NN

hive --service metatool -updateLocation <new-loc> <old-loc>  <- updates the
pointer to NN

 

I hope this helps.

 

Yusaku

 

From: Daniel Klinger <dk@web-computing.de <mailto:dk@web-computing.de> >
Reply-To: "user@ambari.apache.org <mailto:user@ambari.apache.org> "
<user@ambari.apache.org <mailto:user@ambari.apache.org> >
Date: Monday, May 18, 2015 1:10 AM
To: "user@ambari.apache.org <mailto:user@ambari.apache.org> "
<user@ambari.apache.org <mailto:user@ambari.apache.org> >
Subject: Ambari 2.0 - Namenode Moved - ConnectionRefused Error

 

Hi all,

 

ich moved my Namenode to a new Node with Ambari 2.0. The moving itselve
worked fine but now I'm getting a ConnectionRefused-Error an HBase and Hive
(if i run a HiveQuery).

 

Error occurred executing hive query: Error while compiling statement:
FAILED: SemanticException MetaException(message:java.net.ConnectException:
Call From node0.test.local/192.168.1.173 to node1.test.local:8020 failed on
connection exception: java.net.ConnectException: Connection refused; For
more details see: http://wiki.apache.org/hadoop/ConnectionRefused

 

Node1 is my old Namenode. Somewehre there is still node1 as Namnode listed.
But i cant find it. I searched all Config-xml-files there is no entry
regarding node1. Where is the mistake?

 

Greetz

dk


Mime
View raw message