ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "guxiaobo1982" <guxiaobo1...@qq.com>
Subject Ambari 2.0 can't start hive metastore
Date Wed, 22 Apr 2015 09:19:07 GMT
Hi,


I am trying to install a single node cluster with Ambari 2.0, but the metastore service can't
be created with the following error:
Fail: Execution of 'export HIVE_CONF_DIR=/etc/hive/conf.server ; /usr/hdp/current/hive-metastore/bin/schematool
-initSchema -dbType mysql -userName hive -passWord [PROTECTED]' returned 1. Metastore connection
URL:	 jdbc:mysql://lix2.bh.com/hive?createDatabaseIfNotExist=true Metastore Connection Driver
:	 com.mysql.jdbc.Driver Metastore connection User:	 hive org.apache.hadoop.hive.metastore.HiveMetaException:
Failed to get schema version. *** schemaTool failed ***I tried to execute the exact command
on command line, but with the same error, any solution for this?export HIVE_CONF_DIR=/etc/hive/conf.server
; /usr/hdp/current/hive-metastore/bin/schematool -initSchema -dbType mysql -userName hive
-passWord [PROTECTED]Regards,
Mime
View raw message