ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Xiaoyong Zhu <xiaoy...@microsoft.com>
Subject ambari upgrade from 1.7 to 2.0?
Date Fri, 17 Apr 2015 10:07:56 GMT
Hi Experts

I am using Ambari 1.7 with HDP2.2. however, when I want to try Ambari 2.0, Ambari cannot start
with following errors:

17 Apr 2015 08:44:37,331  WARN [main] AmbariServer:592 - Current database store version is
not compatible with current server version, serverVersion=2.0.0, schemaVersion=1.7.0
17 Apr 2015 08:44:37,337 ERROR [main] AmbariServer:690 - Failed to run the Ambari Server
org.apache.ambari.server.AmbariException: Current database store version is not compatible
with current server version, serverVersion=2.0.0, schemaVersion=1.7.0
        at org.apache.ambari.server.controller.AmbariServer.checkDBVersion(AmbariServer.java:593)
        at org.apache.ambari.server.controller.AmbariServer.run(AmbariServer.java:216)
        at org.apache.ambari.server.controller.AmbariServer.main(AmbariServer.java:688)

is there a way I can upgrade to Ambari 2.0 directly without resetting the DB?

Thanks!

Xiaoyong


Mime
View raw message