ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Roberts <srobe...@hortonworks.com>
Subject Re: Default Database Packages | Ambari Repo
Date Fri, 27 Mar 2015 08:19:55 GMT
Pratik - The Ambari repo only provide Ambari packages. For example, these are the packages
provides for rhel/centos6:
  ambari-agent
  ambari-log4j
  ambari-server

They have these dependancies, which means you’ll likely need the OS repositories:

# rpm -qpR ambari-server-1.7.0-169.noarch.rpm
postgresql-server >= 8.1
openssl
python >= 2.6
/bin/sh
/bin/sh
/bin/sh
/bin/sh
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadIsXz) <= 5.2-1


--
Hortonworks - We Do Hadoop

Sean Roberts
Partner Solutions Engineer - EMEA
@seano

On Mar 27, 2015, at 08:03, Pratik Gadiya <pratik_gadiya@persistent.com<mailto:pratik_gadiya@persistent.com>>
wrote:

Hi All,

Can someone tell me which database does ambari-repo provides by default ?

I disabled the local-os repo and tried to setup ambari server.
At that point of time, it raised an exception saying “postgres-server>8.1” required.
So, definitely postgres is not packaged with the ambari-repo.

In addition to that, I tried to look into the ambari-repo, I could find the jdbc-connector
package for mysql but couldn’t find any packages w.r.t mysql or any other database.


With Regards,
Pratik


DISCLAIMER ========== This e-mail may contain privileged and confidential information which
is the property of Persistent Systems Ltd. It is intended only for the use of the individual
or entity to which it is addressed. If you are not the intended recipient, you are not authorized
to read, retain, copy, print, distribute or use this message. If you have received this communication
in error, please notify the sender and delete all copies of this message. Persistent Systems
Ltd. does not accept any liability for virus infected mails.

Mime
View raw message