ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Giovanni Paolo Gibilisco <gibb...@gmail.com>
Subject Java version upgrade
Date Mon, 16 Feb 2015 09:22:47 GMT
Hi,
I'm trying to upgrade the version of Java used in the cluster in order to
support Java 8. I've managed to install Java 8 and set the JAVA_HOME
correctly on all the nodes on the cluster. I've restarted the services
using ambari and even restarted the ambari server and agents but still wehn
i subit a job using yarn i get an exception in my code saying
"Exception in thread "main" java.lang.UnsupportedClassVersionError:
it/polimi/tssotn/dataloader/DataLoader : Unsupported major.minor version
52.0"
that basically means it is not running with Java 8.
Is there a way to tell ambari to confgure yarn (and all other services) so
use the new jre?

Mime
View raw message