ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitry Sen <d...@hortonworks.com>
Subject Re: Java version upgrade
Date Mon, 16 Feb 2015 13:41:52 GMT
Hi Giovanni,


Ambari supports customized JDK :


# ambari-server setup

Using python  /usr/bin/python2.6
Setup ambari-server
Checking SELinux...
SELinux status is 'disabled'
Ambari-server daemon is configured to run under user 'root'. Change this setting [y/n] (n)?
Adjusting ambari-server permissions and ownership...
Checking iptables...
Checking JDK...
Do you want to change Oracle JDK [y/n] (n)? y
[1] Oracle JDK 1.7
[2] Oracle JDK 1.6
[3] - Custom JDK
==============================================================================
Enter choice (1): 3
WARNING: JDK must be installed on all hosts and JAVA_HOME must be valid on all hosts.
WARNING: JCE Policy files are required for configuring Kerberos security. If you plan to use
Kerberos,please make sure JCE Unlimited Strength Jurisdiction Policy Files are valid on all
hosts.
Path to JAVA_HOME: /my/path/to/jdk

...



Thanks,


BR,

Dmytro Sen


________________________________
From: Giovanni Paolo Gibilisco <gibbo87@gmail.com>
Sent: Monday, February 16, 2015 11:22 AM
To: user@ambari.apache.org
Subject: Java version upgrade

Hi,
I'm trying to upgrade the version of Java used in the cluster in order to support Java 8.
I've managed to install Java 8 and set the JAVA_HOME correctly on all the nodes on the cluster.
I've restarted the services using ambari and even restarted the ambari server and agents but
still wehn i subit a job using yarn i get an exception in my code saying
"Exception in thread "main" java.lang.UnsupportedClassVersionError: it/polimi/tssotn/dataloader/DataLoader
: Unsupported major.minor version 52.0"
that basically means it is not running with Java 8.
Is there a way to tell ambari to confgure yarn (and all other services) so use the new jre?

Mime
View raw message