ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Krish Donald <gotomyp...@gmail.com>
Subject Re: Ambari 1.7 error while registering
Date Thu, 22 Jan 2015 04:42:25 GMT
As of now I have installed ambari-agent on all all the nodes and trying to
install.
However I am getting another error :

On my ambari server I have started ambari agent also because that also
should be part of the cluster.
On the node where I have installed ambari-server and ambari-agent both, for
that node I am getting error "Ambari agent is not running on 1 hosts. Show
Details" at Install, Start and Test step of the Ambari setup wizard.

But when I check at the machine it shows ambari-agent is running:

[root@master etc]# service ambari-agent status
Found ambari-agent PID: 20057
ambari-agent running.
Agent PID at: /var/run/ambari-agent/ambari-agent.pid
Agent out at: /var/log/ambari-agent/ambari-agent.out
Agent log at: /var/log/ambari-agent/ambari-agent.log

I am not sure , how to deal with this situation.

On Wed, Jan 21, 2015 at 8:07 PM, Devopam Mittra <devopam@gmail.com> wrote:

> Please try once using the UI by "pasting" the key without any extra
> character in the beginning or end. It might help
>
> I am assuming you have iptables off , have /etc/hosts configured on each
> node (to have FQDN of ALL machines including itself) , have SELinux off ,
>  and configured this file to allow networking properly
> /etc/sysconfig/network/config
> regards
> Devopam
>
>
> On Thu, Jan 22, 2015 at 9:17 AM, Krish Donald <gotomypc27@gmail.com>
> wrote:
>
>> CentOS release 6.6 (Final)
>>
>> I am uploading file authorized_keys which I have SCP from the namenode
>>
>> On Wed, Jan 21, 2015 at 7:42 PM, Devopam Mittra <devopam@gmail.com>
>> wrote:
>>
>>> You might be adding an extra newline character while trying to paste the
>>> ssh key in Ambari web. Please see if that helps.
>>> What is your OS version and which browser are you using on that to
>>> access Ambari ?
>>>
>>> regards
>>> Devopam
>>>
>>>
>>> On Thu, Jan 22, 2015 at 1:33 AM, Krish Donald <gotomypc27@gmail.com>
>>> wrote:
>>>
>>>> Hi Srimanth,
>>>>
>>>> I am able to ssh without password from master to slave1, slave2 and
>>>> slave 3 and vice versa.
>>>>
>>>> Is there anything I should check?
>>>>
>>>> On Wed, Jan 21, 2015 at 11:25 AM, Srimanth Gunturi <
>>>> srimanth@hortonworks.com> wrote:
>>>>
>>>>> Hello,
>>>>> Assuming that the /etc/hosts on each of the 3 machines has the correct
>>>>> IP addresses, and you can manually ssh using the same key from '
>>>>> master.my.com' to 'slave1.my.com'?
>>>>> Regards,
>>>>> Srimanth
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> On Wed, Jan 21, 2015 at 11:14 AM, Newton Alex <nalex@pivotal.io>
>>>>> wrote:
>>>>>
>>>>>> Was the passwordless ssh set up for "root" user?
>>>>>>
>>>>>> If yes, check if the /etc/ssh/sshd_config has "PermitRootLogin"
>>>>>> enabled?
>>>>>>
>>>>>> -
>>>>>> Newton
>>>>>>
>>>>>> On Wed, Jan 21, 2015 at 10:06 AM, Krish Donald <gotomypc27@gmail.com>
>>>>>> wrote:
>>>>>>
>>>>>>> Hi,
>>>>>>>
>>>>>>> I have installed Ambari 1.7 but when I am trying to setup the
>>>>>>> cluster I am getting below error. I have correctly setup passwordless
ssh
>>>>>>> correctly I am able to ssh to all my three slave nodes without
password .
>>>>>>> Not sure why I am getting below error . Please suggest .
>>>>>>>
>>>>>>> ********************************************************
>>>>>>> ==========================
>>>>>>> Creating target directory...
>>>>>>> ==========================
>>>>>>> Command start time 2015-01-21 12:57:04
>>>>>>> Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).
>>>>>>> SSH command execution finished
>>>>>>> host=master.my.com, exitcode=255
>>>>>>> Command end time 2015-01-21 12:57:04
>>>>>>> ERROR: Bootstrap of host master.my.com fails because previous
>>>>>>> action finished with non-zero exit code (255)
>>>>>>> ERROR MESSAGE: Permission denied
>>>>>>> (publickey,gssapi-keyex,gssapi-with-mic,password).
>>>>>>> STDOUT:
>>>>>>> Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).
>>>>>>>
>>>>>>> *************************************************************
>>>>>>>
>>>>>>> Below is some messages which I got from the log:
>>>>>>>
>>>>>>> INFO:root:BootStrapping hosts ['master.my.com', 'slave1.my.com',
'
>>>>>>> slave2.my.com'] using
>>>>>>> /usr/lib/python2.6/site-packages/ambari_server cluster primary
OS: redhat6
>>>>>>> with
>>>>>>> user 'root' sshKey File /var/run/ambari-server/bootstrap/9/sshKey
>>>>>>> password File null using tmp dir /var/run/ambari-server/bootstrap/9
ambari:
>>>>>>> master.my.com; server_port
>>>>>>> : 8080; ambari version: 1.7.0
>>>>>>>
>>>>>>> Thanks
>>>>>>> Krish
>>>>>>>
>>>>>>>
>>>>>>
>>>>>
>>>>> CONFIDENTIALITY NOTICE
>>>>> NOTICE: This message is intended for the use of the individual or
>>>>> entity to which it is addressed and may contain information that is
>>>>> confidential, privileged and exempt from disclosure under applicable
law.
>>>>> If the reader of this message is not the intended recipient, you are
hereby
>>>>> notified that any printing, copying, dissemination, distribution,
>>>>> disclosure or forwarding of this communication is strictly prohibited.
If
>>>>> you have received this communication in error, please contact the sender
>>>>> immediately and delete it from your system. Thank You.
>>>>
>>>>
>>>>
>>>
>>>
>>> --
>>> Devopam Mittra
>>> Life and Relations are not binary
>>>
>>
>>
>
>
> --
> Devopam Mittra
> Life and Relations are not binary
>

Mime
View raw message