ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "guxiaobo1982" <guxiaobo1...@qq.com>
Subject Re: oozie installed by ambari 1.7.0 can't start
Date Tue, 09 Dec 2014 09:52:11 GMT
I add the following line to  /usr/hdp/2.2.0.0-2041/oozie/tomcat-deployment/conf/catalina.properties,
but it still does not work,
because I think it is because tomcat can't find the tomcat-juli.jar file
 

 
server.loader=/usr/lib/bigtop-tomcat/bin/*.jar





------------------ Original ------------------
From:  "guxiaobo1982";<guxiaobo1982@qq.com>;
Send time: Tuesday, Dec 9, 2014 5:32 PM
To: "user"<user@ambari.apache.org>; 

Subject:  oozie installed by ambari 1.7.0 can't start



Hi,


I installed a single node hadoop environment via ambari 1.17.0, but the oozie service can't
start, I found the tomcat service can't find a log4j related class, here's the error message
from more /var/log/oozie/catalina.out
 

 
[root@lix1 oozie]# more catalina.out 
 
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/juli/logging/LogFactory
 
	at org.apache.catalina.startup.Bootstrap.<clinit>(Bootstrap.java:59)
 
Caused by: java.lang.ClassNotFoundException: org.apache.juli.logging.LogFactory
 
	at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
 
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
 
	at java.security.AccessController.doPrivileged(Native Method)
 
	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
 
	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
 
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
 
	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
 
	... 1 more
Mime
View raw message