ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Sposetti <j...@hortonworks.com>
Subject Re: Ambari-agent installation (started from UI) failed on SUSE 11 sp3
Date Sat, 26 Jul 2014 02:06:08 GMT
>From the Ambari 1.6.1 release notes, this is a known issue.

*BUG-20060:* Host registration fails during Agent bootstrap on SLES due to
timeout.

http://docs.hortonworks.com/HDPDocuments/Ambari-1.6.1.0/bk_releasenotes_ambari_1.6.1/content/ch_relnotes-ambari-1.6.1.0-knownissues.html


On Fri, Jul 25, 2014 at 10:00 PM, Zongheng Yang <zongheng.y@gmail.com>
wrote:

> Hmm, not sure if the following behavior causes the issue. After
> manually killing the two stuck processes, I ran "zypper -q search -s
> --match-exact ambari-agent", and it prompts for user interaction:
>
> New repository or package signing key received:
> Key ID: F5113243C66B6EAE
> Key Name: NVIDIA Corporation <linux-bugs@nvidia.com>
> Key Fingerprint: 9B763D49D8A5C892FC178BACF5113243C66B6EAE
> Key Created: Thu 15 Jun 2006 04:13:18 PM UTC
> Key Expires: (does not expire)
> Repository: nVidia-Driver-SLE11-SP3
>
> Do you want to reject the key, trust temporarily, or trust always?
> [r/t/a/?] (r):
>
> Is this the expected behavior? It seems to be the Ambari installation
> process should be able to automate all command-line processes and
> requires user attention only on the UI.
>
> On Fri, Jul 25, 2014 at 6:57 PM, Zongheng Yang <zongheng.y@gmail.com>
> wrote:
> > Hi user@ambari,
> >
> > I am trying to use Ambari 1.6.1 to install HDP 2.1 on a two-machine
> > cluster (EC2 r3.large instances, SUSE Linux Enterprise Server 11 sp3).
> > I have successfully installed and started the Ambari server, and in
> > the web UI's "Confirm Hosts" step, the installation failed.
> >
> > Here's the log for one of the hosts: http://pastebin.com/6JMMbaDL
> >
> > Doing a "ps aux | grep zypper" on that host gives:
> >
> > ip-172-31-18-208:~ # ps aux | grep zypper
> > root     19622  0.0  0.0  11584  1452 pts/1    S+   01:41   0:00 bash
> > -c zypper -q search -s --match-exact ambari-agent | grep ambari-agent
> > | sed -re 's/\s+/ /g' | cut -d '|' -f 4 | tr '\n' ', ' | sed -s
> > 's/[-|~][A-Za-z0-9]*//g'
> > root     19623  0.5  0.0 113112 12208 pts/1    S+   01:41   0:00
> > zypper -q search -s --match-exact ambari-agent
> > root     20135  0.0  0.0   5716   820 pts/0    S+   01:41   0:00 grep
> zypper
> >
> > The top two processes seem to be long-lived/stuck. And `zypper install
> > ambari-agent` on that host gives:
> >
> > System management is locked by the application with pid 19623 (zypper).
> > Close this application before trying again.
> >
> > I am wondering, what's the root cause here, and how can I resolve this
> > issue? I am happy to provide more details if that's helpful for
> > diagnosis.
> >
> > Cheers,
> > Zongheng
>

-- 
CONFIDENTIALITY NOTICE
NOTICE: This message is intended for the use of the individual or entity to 
which it is addressed and may contain information that is confidential, 
privileged and exempt from disclosure under applicable law. If the reader 
of this message is not the intended recipient, you are hereby notified that 
any printing, copying, dissemination, distribution, disclosure or 
forwarding of this communication is strictly prohibited. If you have 
received this communication in error, please contact the sender immediately 
and delete it from your system. Thank You.

Mime
View raw message