ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yusaku Sako <yus...@hortonworks.com>
Subject Re: Ambari service install/start errors
Date Thu, 03 Jul 2014 01:25:46 GMT
Hi Yixiao,

Ambari Server can run as any user (does not need to be root).
However, you need to tell Ambari what user Ambari should run as (can be set
with "ambari-server setup" command).
However, I think your question has more to do with agents as you are
talking about deployment.
Currently, Ambari Agent has to run as root, and it would run as the same
context when you start it via "ambari-agent start" as root user.
(Others on the mailing list, please correct me if I'm wrong)

Yusaku


On Fri, Jun 27, 2014 at 8:24 AM, Yixiao Lin <yixiao@yahoo-inc.com> wrote:

> Hi all,
>
> So I found that my environment variables are being messed up because some
> previous Hadoop deployment.
> Now I want to know that if I run the server as root, which profile will be
> sourced when the Ambari-server starts a deployment? Is it the same as if I
> use a shell and ssh to my host as root? ps. I am not setting up ssh on the
> hosts, I set up the agents manually.
>
> Thank you in advance,
> Yixiao
>
>
>   On Thursday, June 26, 2014 10:52 AM, Yixiao Lin <yixiao@yahoo-inc.com>
> wrote:
>
>
> Hi all,
>
> This is Yixiao from Yahoo. I am encountering some problems using the webUI
> to deploy/start services.
> I have configured my ambari(1.6.0) agents manually on RHEL 6, one server,
> three agents(including one same host as server). I have deployed some basic
> Hadoop services: HDFS, YARN+MapReduce2, teZ, Nagios and Zookeeper. However,
> now I am unable to start the History server of MapReduce2 or the
> Nodemanager of YARN. When I start them, they all run into the same error:
> The error occurred when the script hit this command:
> $ hadoop fs -mkdir
>    Error: Could not find or load main class org.apache.hadoop.fs.FsShell
>
> So I tried to run
> $ hadoop version
>    Error: Could not find or load main class
> org.apache.hadoop.util.VersionInfo
> $ echo $PATH
>
>  /usr/kerberos/bin:/usr/lib64/qt-3.3/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/gs/java/jdk/bin:/home/gs/hadoop/current/bin:/home/gs/hbase/current/bin:/home/gs/pig/bin:/home/gs/pig/current/bin:/gridtools/generic/bin
>
> $ echo $HADOOP_CLASSPATH
>
> $ export
> HADOOP_CLASSPATH=/home/gs/hadoop/current/share/hadoop/common/hadoop-common-2.4.0.5.1406161905.jar
> $ hadoop version
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/commons/logging/LogFactory
>
> It seems I don't have correct HADOOP_CLASSPATH configured
>
> Does anyone know a possible solution to this?
> When I installed the agents, what are the environment assumptions? I did
> this when I was installing the agents, am I missing some steps?
> $ cd /etc/yum.repos.d/
> $ wget
> http://public-repo-1.hortonworks.com/ambari/centos6/1.x/updates/1.6.0/ambari.repo
> $ yum install ambari-agent
>
> Edit /etc/ambari-agent/conf/ambari-agent.ini
>
> $ ambari-agent start
>
> Thank you in advance,
> Yixiao
>
>
>

-- 
CONFIDENTIALITY NOTICE
NOTICE: This message is intended for the use of the individual or entity to 
which it is addressed and may contain information that is confidential, 
privileged and exempt from disclosure under applicable law. If the reader 
of this message is not the intended recipient, you are hereby notified that 
any printing, copying, dissemination, distribution, disclosure or 
forwarding of this communication is strictly prohibited. If you have 
received this communication in error, please contact the sender immediately 
and delete it from your system. Thank You.

Mime
View raw message