ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Siddharth Wagle <swa...@hortonworks.com>
Subject Re: ambari upgrade
Date Thu, 17 Jul 2014 20:13:11 GMT
Hi Emine,

Do take a look at this page,
https://cwiki.apache.org/confluence/display/AMBARI/Adding+a+New+Service+to+an+Existing+Cluster

Essentially, you need update a file in the stack and then use Ambari API to
add a component.

Note: Be careful of upgrading Ambari, you should backup your changes to the
stacks before upgrade since, custom stack would be lost with upgrade. There
is already a Jira open to fix this upgrade issue.

Copy user group, in case there is more input.

Best Regards,
Sid


On Thu, Jul 17, 2014 at 1:03 PM, ILOGLU, EMINE <ei947t@att.com> wrote:

>  Hi Siddhart,
>
>
>
> How do you add a service component to the stack?
>
>
>
> Thanks
>
>
>
> *Emine Iloglu*
>
> AT&T - System Architecture & Applied Technology (SAAT)
>
> T: 848-218-2108 | Q: ei947t
>
> (Remote, Eastern Timezone)
>
>
>
>
>
> *From:* Siddharth Wagle [mailto:swagle@hortonworks.com]
> *Sent:* Monday, June 30, 2014 12:07 PM
>
> *To:* user@ambari.apache.org
> *Subject:* Re: ambari upgrade
>
>
>
> Hi Emine,
>
> This would happen if, you had custom service components defined in the
> stack definition before the upgrade.
>
> Ambari upgrade would override the stack definition with newer versions of
> the stack, example HDP-1.3.3 and the service component that was added
> previously to the XML definition would no longer be availble to Ambari
> server.
>
> If you look at the /var/log/ambari-server/ambari-sever.log, you should be
> able to see a ServiceComponentNotFoundException with the name to the
> service component that is missing.
>
>
>
> Solution:
>
> 1. Add the definition of the service component to the stack and restart
> the server.
>
> 2. This is a little bit more involved:
>
>   - Check the relationships for the service component from the servicecomponentdesiredstate
> outwards.
>
>   - If no relationships exists delete the row from
> servicecomponentdesiredstate.
>
>   - If there is a host component for the foreign service component, it
> better to go with solution 1, since it will involve only XML edits and no
> changing of DB state.
>
>   - A service component can be deleted only when all its child host
> components are deleted.
>
> Best Regards,
>
> Sid
>
>
>
> On Mon, Jun 30, 2014 at 8:05 AM, ILOGLU, EMINE <ei947t@att.com> wrote:
>
> This is a mystery to me. At each attempt a different service/services
> disappear from the UI and sometimes they are all fine.. Any idea what could
> be the root cause? The postgress db shows all the services as
> INSTALLED/STARTED state.
>
>
>
> *Emine Iloglu*
>
> AT&T - Common Services Systems Architecture (CSSA)
>
> T: 848-218-2108 | Q: ei947t
>
> (Remote, Eastern Timezone)
>
>
>
>
>
> *From:* Nate Cole [mailto:ncole@hortonworks.com]
> *Sent:* Monday, June 30, 2014 11:02 AM
>
>
> *To:* user@ambari.apache.org
> *Subject:* Re: ambari upgrade
>
>
>
> The public-repo is only trying to determine information about stacks, but
> does not affect existing clusters.
>
> On 6/30/14 10:51 AM, ILOGLU, EMINE wrote:
>
> From 1.4.4 to 1.6.0
>
> HDP is 1.3.3 , using an internal repo
>
>
>
> After the upgrade, I see this in the log file:
>
> 07:38:22,307  INFO [main] StackExtensionHelper:358 - No services defined
> for stack: HDP-1.3.3
>
> 07:38:23,229  INFO [Stack Version Loading Thread] LatestRepoCallable:73 -
> Loading latest URL info from
> http://public-repo-1.hortonworks.com/HDP/hdp_urlinfo.json
>
> 07:38:25,233 ERROR [Stack Version Loading Thread] LatestRepoCallable:90 -
> Could not load the URI
> http://public-repo-1.hortonworks.com/HDP/hdp_urlinfo.json (connect timed
> out)
>
> 07:38:25,233  INFO [Stack Version Loading Thread] LatestRepoCallable:73 -
> Loading latest URL info from
> http://public-repo-1.hortonworks.com/HDP/hdp_urlinfo.json
>
> 07:38:27,236 ERROR [Stack Version Loading Thread] LatestRepoCallable:90 -
> Could not load the URI
> http://public-repo-1.hortonworks.com/HDP/hdp_urlinfo.json (connect timed
> out)
>
> 07:38:27,237  INFO [Stack Version Loading Thread] LatestRepoCallable:73 -
> Loading latest URL info from
> http://public-repo-1.hortonworks.com/HDP/hdp_urlinfo.json
>
> 07:38:29,244 ERROR [Stack Version Loading Thread] LatestRepoCallable:90 -
> Could not load the URI
> http://public-repo-1.hortonworks.com/HDP/hdp_urlinfo.json (Read timed out)
>
> 07:38:29,248  WARN [main] ActionDefinitionManager:117 - Ignoring action
> definition as a different definition by that name already exists.
> ActionDefinition: actionName: ambari_hdfs_rebalancer actionType: SYSTEM
> inputs: threshold,[principal],[keytab] description: HDFS Rebalance
> targetService: HDFS targetComponent: NAMENODE defaultTimeout: 600
> targetType: ANY
>
> 07:38:29,248  WARN [main] ActionDefinitionManager:117 - Ignoring action
> definition as a different definition by that name already exists.
> ActionDefinition: actionName: nagios_update_ignore actionType: SYSTEM
> inputs: [nagios_ignore] description: Used to create an alert blackout
> targetService: NAGIOS targetComponent: NAGIOS_SERVER defaultTimeout: 60
> targetType: ANY
>
>
>
> And at this attempt to upgrade, I see HDFS and Nagios are missing and all
> the other services do exist.
>
> Why is it trying to go public-repo? That might be the problem right?
>
>
>
> Thanks
>
> *Emine Iloglu*
>
> AT&T - Common Services Systems Architecture (CSSA)
>
> T: 848-218-2108 | Q: ei947t
>
> (Remote, Eastern Timezone)
>
>
>
>
>
> *From:* Sumit Mohanty [mailto:smohanty@hortonworks.com
> <smohanty@hortonworks.com>]
> *Sent:* Monday, June 30, 2014 10:46 AM
> *To:* user@ambari.apache.org
> *Subject:* Re: ambari upgrade
>
>
>
> What version did you upgrade from? What is the version of stack?
>
>
>
> What does these calls return (assumes default login/password - change it
> as needed?
>
>
>
> curl-u admin:admin http://<ambari server
> host>:8080/api/v1/clusters/<clustername>
>
> curl-u admin:admin http://<ambari server
> host>:8080/api/v1/clusters/<clustername>/services
>
>
>
> On Mon, Jun 30, 2014 at 6:45 AM, ILOGLU, EMINE <ei947t@att.com> wrote:
>
> Hi all,
>
>
>
> After I upgrade ambari to 1.6.0, I don’t see any servers on the ambari UI,
> however they are all in postgress in hostcomponentdesiredstate and
> servicecomponentdesiredstate tables.
>
>
>
> Any ideas?
>
>
>
> *Emine Iloglu*
>
> AT&T - Common Services Systems Architecture (CSSA)
>
> T: 848-218-2108 | Q: ei947t
>
> (Remote, Eastern Timezone)
>
>
>
>
> CONFIDENTIALITY NOTICE
> NOTICE: This message is intended for the use of the individual or entity
> to which it is addressed and may contain information that is confidential,
> privileged and exempt from disclosure under applicable law. If the reader
> of this message is not the intended recipient, you are hereby notified that
> any printing, copying, dissemination, distribution, disclosure or
> forwarding of this communication is strictly prohibited. If you have
> received this communication in error, please contact the sender immediately
> and delete it from your system. Thank You.
>
>
>
>
> CONFIDENTIALITY NOTICE
> NOTICE: This message is intended for the use of the individual or entity
> to which it is addressed and may contain information that is confidential,
> privileged and exempt from disclosure under applicable law. If the reader
> of this message is not the intended recipient, you are hereby notified that
> any printing, copying, dissemination, distribution, disclosure or
> forwarding of this communication is strictly prohibited. If you have
> received this communication in error, please contact the sender immediately
> and delete it from your system. Thank You.
>
>
>
>
> CONFIDENTIALITY NOTICE
> NOTICE: This message is intended for the use of the individual or entity
> to which it is addressed and may contain information that is confidential,
> privileged and exempt from disclosure under applicable law. If the reader
> of this message is not the intended recipient, you are hereby notified that
> any printing, copying, dissemination, distribution, disclosure or
> forwarding of this communication is strictly prohibited. If you have
> received this communication in error, please contact the sender immediately
> and delete it from your system. Thank You.
>

-- 
CONFIDENTIALITY NOTICE
NOTICE: This message is intended for the use of the individual or entity to 
which it is addressed and may contain information that is confidential, 
privileged and exempt from disclosure under applicable law. If the reader 
of this message is not the intended recipient, you are hereby notified that 
any printing, copying, dissemination, distribution, disclosure or 
forwarding of this communication is strictly prohibited. If you have 
received this communication in error, please contact the sender immediately 
and delete it from your system. Thank You.

Mime
View raw message