ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Suraj Nayak M <snay...@gmail.com>
Subject How to run Ambari Server Locally
Date Fri, 11 Jul 2014 14:50:15 GMT
Hi All,

I want to run AmbariServer for local debugging. I tried the below process

I went through the 
https://cwiki.apache.org/confluence/display/AMBARI/Ambari+Development 
confluence page to see how I can develop or modify few components of 
Ambari. I was able to get the *ambari-web *project running locally 
(without backend running) successfully. However, I did not find how to 
setup & run AmbariServer locally.
How can I run the *ambari-server *locally to test or debug the changes 
in the code locally(through eclipse) ? I tried to run 
the***org.apache.ambari.server.controller.AmbariServer* with argument as 
-Xms512m -Xmx1024m, but got errors. Eclipse log attached with this mail.

*ambari.properties* with following data :

/metadata.path=src/main/resources/stacks//
//server.version.file=target/version//
//server.jdbc.database=ambari//
//server.os_type=debian12//

/I tried jetty:run as goal for *ambari-server *maven project. It throws 
error mentioned below :

/[ERROR] No plugin found for prefix 'jetty' in the current project and 
in the plugin groups [org.apache.maven.plugins, org.codehaus.mojo] 
available from the repositories [local (/home/snayakm/.m2/repository), 
maven2-repository.dev.java.net (http://download.java.net/maven/2/), 
maven2-glassfish-repository.dev.java.net 
(http://download.java.net/maven/glassfish/), maven2-repository.atlassian 
(https://maven.atlassian.com/repository/public), central 
(http://repo.maven.apache.org/maven2)] -> [Help 1]//
//
/Need help in running Ambari Server in local mode.

--
Suraj Nayak

Mime
View raw message