ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ÐΞ€ρ@Ҝ (๏̯͡๏) <deepuj...@gmail.com>
Subject Upgrade to 1.6.0 from 1.5.1.110 (AMBARI-5997)
Date Tue, 03 Jun 2014 09:26:06 GMT
One my hosts i ran the following commands

ambari-agent stop
wget
http://public-repo-1.hortonworks.com/ambari/centos6/1.x/updates/1.6.0/ambari.repo

cp ambari.repo /etc/yum.repos.d/ambari.repo
yum upgrade ambari-agent ambari-log4j

I see the below error


# yum upgrade ambari-agent ambari-log4j
Loaded plugins: product-id

Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package ambari-agent.x86_64 0:1.5.1.110-1 will be updated
---> Package ambari-agent.x86_64 0:1.6.0-46 will be an update
--> Processing Dependency: python26 for package:
ambari-agent-1.6.0-46.x86_64
---> Package ambari-log4j.noarch 0:1.5.1.110-1 will be updated
---> Package ambari-log4j.noarch 0:1.6.0.46-1 will be an update
--> Running transaction check
---> Package python26.x86_64 0:2.6.8-2.el5 will be installed
--> Processing Dependency: libdb-4.3.so()(64bit) for package:
python26-2.6.8-2.el5.x86_64
--> Processing Dependency: libcrypto.so.6()(64bit) for package:
python26-2.6.8-2.el5.x86_64
--> Processing Dependency: libssl.so.6()(64bit) for package:
python26-2.6.8-2.el5.x86_64
--> Processing Dependency: libtermcap.so.2()(64bit) for package:
python26-2.6.8-2.el5.x86_64
--> Running transaction check
---> Package compat-db43.x86_64 0:4.3.29-15.el6 will be installed
---> Package compat-libtermcap.x86_64 0:2.0.8-49.el6 will be installed
---> Package openssl098e.x86_64 0:0.9.8e-17.el6_2.2 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================================
 Package                          Arch                  Version
               Repository                         Size
===================================================================================================================================
Updating:
 ambari-agent                     x86_64                1.6.0-46
                Updates-ambari                    7.9 M
 ambari-log4j                     noarch                1.6.0.46-1
                Updates-ambari                    537 k
Installing for dependencies:
 compat-db43                      x86_64                4.3.29-15.el6
               ebay-rhel-repo                    874 k
 compat-libtermcap                x86_64                2.0.8-49.el6
                ebay-rhel-repo                     16 k
 openssl098e                      x86_64                0.9.8e-17.el6_2.2
               ebay-rhel-repo                    761 k
 python26                         x86_64                2.6.8-2.el5
               HDP-UTILS-1.1.0.17                6.5 M

Transaction Summary
===================================================================================================================================
Install       4 Package(s)
Upgrade       2 Package(s)

Total size: 17 M
Is this ok [y/N]: Exiting on user Command
[root@datanode-21-281973 upgrade]# yum upgrade ambari-agent ambari-log4j
Loaded plugins: product-id
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package ambari-agent.x86_64 0:1.5.1.110-1 will be updated
---> Package ambari-agent.x86_64 0:1.6.0-46 will be an update
--> Processing Dependency: python26 for package:
ambari-agent-1.6.0-46.x86_64
---> Package ambari-log4j.noarch 0:1.5.1.110-1 will be updated
---> Package ambari-log4j.noarch 0:1.6.0.46-1 will be an update
--> Running transaction check
---> Package python26.x86_64 0:2.6.8-2.el5 will be installed
--> Processing Dependency: libdb-4.3.so()(64bit) for package:
python26-2.6.8-2.el5.x86_64
--> Processing Dependency: libcrypto.so.6()(64bit) for package:
python26-2.6.8-2.el5.x86_64
--> Processing Dependency: libssl.so.6()(64bit) for package:
python26-2.6.8-2.el5.x86_64
--> Processing Dependency: libtermcap.so.2()(64bit) for package:
python26-2.6.8-2.el5.x86_64
--> Running transaction check
---> Package compat-db43.x86_64 0:4.3.29-15.el6 will be installed
---> Package compat-libtermcap.x86_64 0:2.0.8-49.el6 will be installed
---> Package openssl098e.x86_64 0:0.9.8e-17.el6_2.2 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================================
 Package                          Arch                  Version
               Repository                         Size
===================================================================================================================================
Updating:
 ambari-agent                     x86_64                1.6.0-46
                Updates-ambari                    7.9 M
 ambari-log4j                     noarch                1.6.0.46-1
                Updates-ambari                    537 k
Installing for dependencies:
 compat-db43                      x86_64                4.3.29-15.el6
               ebay-rhel-repo                    874 k
 compat-libtermcap                x86_64                2.0.8-49.el6
                ebay-rhel-repo                     16 k
 openssl098e                      x86_64                0.9.8e-17.el6_2.2
               ebay-rhel-repo                    761 k
 python26                         x86_64                2.6.8-2.el5
               HDP-UTILS-1.1.0.17                6.5 M

Transaction Summary
===================================================================================================================================
Install       4 Package(s)
Upgrade       2 Package(s)

Total size: 17 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
  file /usr/lib64/python2.6/distutils/README from install of
python26-2.6.8-2.el5.x86_64 conflicts with file from package
python-2.6.6-29.el6_3.3.x86_64
  file /usr/lib64/python2.6/site-packages/README from install of
python26-2.6.8-2.el5.x86_64 conflicts with file from package
python-2.6.6-29.el6_3.3.x86_64
  file /usr/lib64/python2.6/idlelib/README.txt from install of
python26-2.6.8-2.el5.x86_64 conflicts with file from package
python-2.6.6-29.el6_3.3.x86_64
  file /usr/lib64/python2.6/lib-dynload/dbm.so from install of
python26-2.6.8-2.el5.x86_64 conflicts with file from package
python-2.6.6-29.el6_3.3.x86_64
  file /usr/lib64/python2.6/lib-dynload/readline.so from install of
python26-2.6.8-2.el5.x86_64 conflicts with file from package
python-2.6.6-29.el6_3.3.x86_64
  file /usr/lib64/python2.6/lib-dynload/syslog.so from install of
python26-2.6.8-2.el5.x86_64 conflicts with file from package
python-2.6.6-29.el6_3.3.x86_64
  file /usr/lib64/python2.6/bsddb/__init__.py from install of
python26-2.6.8-2.el5.x86_64 conflicts with file from package
python-2.6.6-29.el6_3.3.x86_64
  file /usr/lib64/python2.6/compiler/__init__.py from install of
python26-2.6.8-2.el5.x86_64 conflicts with file from package
python-2.6.6-29.el6_3.3.x86_64
  file /usr/lib64/python2.6/ctypes/__init__.py from install of
python26-2.6.8-2.el5.x86_64 conflicts with file from package
python-2.6.6-29.el6_3.3.x86_64
  file /usr/lib64/python2.6/ctypes/macholib/__init__.py from install of
python26-2.6.8-2.el5.x86_64 conflicts with file from package
python-2.6.6-29.el6_3.3.x86_64
  file /usr/lib64/python2.6/curses/__init__.py from install of
python26-2.6.8-2.el5.x86_64 conflicts with file from package
python-2.6.6-29.el6_3.3.x86_64
  file /usr/lib64/python2.6/distutils/__init__.py from install of
python26-2.6.8-2.el5.x86_64 conflicts with file from package
python-2.6.6-29.el6_3.3.x86_64
  file /usr/lib64/python2.6/distutils/command/__init__.py from install of
python26-2.6.8-2.el5.x86_64 conflicts with file from package
python-2.6.6-29.el6_3.3.x86_64
  file /usr/lib64/python2.6/email/__init__.py from install of
python26-2.6.8-2.el5.x86_64 conflicts with file from package
python-2.6.6-29.el6_3.3.x86_64
  file /usr/lib64/python2.6/email/mime/__init__.py from install of
python26-2.6.8-2.el5.x86_64 conflicts with file from package
python-2.6.6-29.el6_3.3.x86_64
  file /usr/lib64/python2.6/encodings/__init__.py from install of
python26-2.6.8-2.el5.x86_64 conflicts with file from package
python-2.6.6-29.el6_3.3.x86_64



Python packages
# rpm -qa | grep python
dbus-python-0.83.0-6.1.el6.x86_64
python-kerberos-1.1-6.2.el6.x86_64
python-pycurl-7.19.0-8.el6.x86_64
python-setuptools-0.6.10-3.el6.noarch
python-libs-2.6.6-29.el6_3.3.x86_64
python-dmidecode-3.10.13-1.el6.x86_64
libipa_hbac-python-1.8.0-32.el6.x86_64
python-markdown-2.0.1-3.1.el6.noarch
python-netaddr-0.7.5-4.el6.noarch
python-iniparse-0.3.1-2.1.el6.noarch
python-ldap-2.3.10-1.el6.x86_64
libselinux-python-2.0.94-5.3.el6.x86_64
python-crypto-2.0.1-22.el6.x86_64
python-boto-2.5.2-3.el6.noarch
python-gudev-147.1-4.el6_0.1.x86_64
python-pip-0.8-1.el6.noarch
libxml2-python-2.7.6-8.el6_3.4.x86_64
python-rhsm-0.99.12-1.el6.noarch
python-rrdtool-1.4.5-1.el6.x86_64
libreport-python-2.0.9-5.el6_3.2.x86_64
rpm-python-4.8.0-27.el6.x86_64
ganglia-gmond-modules-python-3.5.0-99.x86_64
ipa-python-2.2.0-17.el6_3.1.x86_64
python-ethtool-0.6-1.el6.x86_64
python-simplejson-2.0.9-3.1.el6.x86_64
python-nss-0.11-3.el6.x86_64
python-paramiko-1.7.5-2.1.el6.noarch
python-cheetah-2.4.1-1.el6.x86_64
python-configobj-4.6.0-3.el6.noarch
python-matplotlib-0.99.1.2-1.el6.x86_64
python-iwlib-0.1-1.2.el6.x86_64
python-2.6.6-29.el6_3.3.x86_64
newt-python-0.52.11-3.el6.x86_64
abrt-addon-python-2.0.8-6.el6_3.2.x86_64
python-dateutil-1.4.1-6.el6.noarch
python-pygments-1.1.1-1.el6.noarch
python-krbV-1.0.90-3.el6.x86_64
python-lxml-2.2.3-1.1.el6.x86_64
python-urlgrabber-3.9.1-8.el6.noarch
python-nose-0.10.4-3.1.el6.noarch
[root@datanode-21-281973 upgrade]#



Any fix ?




More details: https://issues.apache.org/jira/browse/AMBARI-5997

Mime
View raw message