ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ÐΞ€ρ@Ҝ (๏̯͡๏) <deepuj...@gmail.com>
Subject Re: Ambari 1.6.0 installation error
Date Tue, 24 Jun 2014 13:35:56 GMT
Use root and don;t change a thing, leave everything as default. it works
smooth


On Tue, Jun 24, 2014 at 6:42 PM, Greg Hill <greg.hill@rackspace.com> wrote:

>  Having just done this on Friday, I can confirm that doing it as root
> works.  The vagrant scripts installed the same key to both the vagrant and
> root users, so all I had to do was upload the insecure_private_key file in
> the Ambari UI and it worked fine.  I left everything else at the defaults.
>
>  Greg
>
>   From: "ÐΞ€ρ@Ҝ (๏̯͡๏)" <deepujain@gmail.com>
> Reply-To: "user@ambari.apache.org" <user@ambari.apache.org>
> Date: Tuesday, June 24, 2014 6:55 AM
> To: user <user@ambari.apache.org>
> Subject: Re: Ambari 1.6.0 installation error
>
>   Hello,
> I had faced the exact same error and the user must be root, otherwise it
> does not work.
> It did not work with my user upon switching to root everything worked.
> You will need to get private key of root@ambari-server and copy public
> certificate of root@ambari-server into all the compute nodes.
>
>  Switch to root and everything will be dead smooth :)
> Regards,
> Deepak
>
>
>
> On Tue, Jun 24, 2014 at 5:13 PM, Dimitris Bouras <dmpour23@gmail.com>
> wrote:
>
>>  Thank you both for your promt reply
>>
>> Deepak, I will try out your solution thanks.
>>
>>  Yusako, I still cannot seem to install the ambari-cluster following the
>> quick start guide. I have attached my steps in a "steps.txt" please point
>> out any steps I might be missing or user privileges that may be involved.
>>
>>  Furthermore i have attached the console output of installation and the
>> tail of  /ambari-server.log & (ui logs)  for both cases as root and vagrant
>> using same insecure key. I cant seem to get to work with either.
>>
>>  Thanks in advance for your help
>>
>>  Dimitri
>>
>>
>>
>>
>>
>>
>> On Tue, Jun 24, 2014 at 12:59 AM, Yusaku Sako <yusaku@hortonworks.com>
>> wrote:
>>
>>> Hi all,
>>>
>>> The Quick Start Guide [1] was missing the step to copy the
>>> insecure_priviate_key file to the OS-specific project folder.
>>> The Wiki has been updated to add this step.
>>> You don't need to manually distribute or configure SSH on all VMs.  Once
>>> the insecure_private_key file is in place in the project folder,
>>> bootstrap.sh does the rest (including passwordless ssh login for root).
>>>
>>> [1] https://cwiki.apache.org/confluence/display/AMBARI/Quick+Start+Guide
>>>
>>> Yusaku
>>>
>>>
>>> On Mon, Jun 23, 2014 at 7:41 AM, Deepak <deepujain@gmail.com> wrote:
>>>
>>>>  Hello
>>>> I have had similar error.
>>>> You need to store ssh public key of ambari server into root user of
>>>> .ssh/authorized_keys file in every host you add using web GUI. This must
be
>>>> done manually. Remember its root user and not any other user.
>>>>
>>>> Sent from my iPhone
>>>>
>>>> On 23-Jun-2014, at 7:35 pm, Dimitris Bouras <dmpour23@gmail.com> wrote:
>>>>
>>>>   Thanks,
>>>>
>>>>  Shouldn't the shell command in bootstrap.sh do this fo rme?
>>>>
>>>> mkdir -p /root/.ssh; chmod 600 /root/.ssh; cp
>>>> /home/vagrant/.ssh/authorized_keys /root/.ssh/
>>>>
>>>>
>>>> On Mon, Jun 23, 2014 at 3:05 PM, Olivier Renault <
>>>> orenault@hortonworks.com> wrote:
>>>>
>>>>> It's probably a good assumption. You need to have distributed the
>>>>> public ssh key to every hosts ahead of time.
>>>>>
>>>>> An alternative is to install ambari-agent on each node, configured it
>>>>> (edit /etc/ambari-agent/conf/ambari-agent.conf and point it to your
>>>>> ambari-server) and start the agent.
>>>>>
>>>>> Thanks
>>>>> Olivier
>>>>>  On 23 Jun 2014 12:48, "Dimitris Bouras" <dmpour23@gmail.com> wrote:
>>>>>
>>>>>>
>>>>>> The steps I follow to setup ambari are based on the Quick start Guide
>>>>>> are:
>>>>>>
>>>>>> 1)cd centos6.5
>>>>>> 2)./up.sh 3
>>>>>> 3) vagrant ssh c6501
>>>>>> 4) sudo su -
>>>>>> 4a) yum install wget
>>>>>> 5) wget
>>>>>> http://public-repo-1.hortonworks.com/ambari/centos6/1.x/updates/1.6.0/ambari.repo
>>>>>> ..setup star...etc.
>>>>>> 6) login to c6501:8080
>>>>>> 7) Define my range expression:
>>>>>> c65[01-03].ambari.apache.org
>>>>>>
>>>>>> Specify the the non-root SSH user vagrant, and upload
>>>>>> insecure_private_key file that I copied earlier as the private key.
>>>>>>
>>>>>> Here is where the process fails, probably due to me not setting up
>>>>>> passwordless ssh. Is this a correct assumption ?
>>>>>> or is there some other kind of error in my setup ? (since the vagrant
>>>>>> insecure key should do the trick?)
>>>>>> Kind regards
>>>>>>
>>>>>> Dimitri
>>>>>>
>>>>>>
>>>>>  CONFIDENTIALITY NOTICE
>>>>> NOTICE: This message is intended for the use of the individual or
>>>>> entity to which it is addressed and may contain information that is
>>>>> confidential, privileged and exempt from disclosure under applicable
law.
>>>>> If the reader of this message is not the intended recipient, you are
hereby
>>>>> notified that any printing, copying, dissemination, distribution,
>>>>> disclosure or forwarding of this communication is strictly prohibited.
If
>>>>> you have received this communication in error, please contact the sender
>>>>> immediately and delete it from your system. Thank You.
>>>>
>>>>
>>>>
>>>
>>> CONFIDENTIALITY NOTICE
>>> NOTICE: This message is intended for the use of the individual or entity
>>> to which it is addressed and may contain information that is confidential,
>>> privileged and exempt from disclosure under applicable law. If the reader
>>> of this message is not the intended recipient, you are hereby notified that
>>> any printing, copying, dissemination, distribution, disclosure or
>>> forwarding of this communication is strictly prohibited. If you have
>>> received this communication in error, please contact the sender immediately
>>> and delete it from your system. Thank You.
>>>
>>
>>
>
>
>  --
>  Deepak
>
>


-- 
Deepak

Mime
View raw message