ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From EdwardKing <zhan...@neusoft.com>
Subject Re: Can't install ambari
Date Thu, 26 Jun 2014 06:17:34 GMT
Thanks Ravi, I download node-v0.10.29-linux-x86.tar.gz and apache-maven-3.0.5-bin.tar.gz, then
I run following again
[root@localhost ambari-1.4.3]# mvn -B clean install package rpm:rpm -DnewVersion=1.4.3 -DskipTests
-Dpython.ver="python >= 2.6"

it raise another error,like follows:
[ERROR] The goal you specified requires a project to execute but there is no POM in this directory
(/opt/yarn). Please verify you invoked Maven from the correct directory. -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following
articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MissingProjectException
[yarn@localhost yarn]$ 

I guess that it may loss another program, how can I do it?  Thanks.

  ----- Original Message ----- 
  From: Ravi Mutyala 
  To: user@ambari.apache.org 
  Sent: Thursday, June 26, 2014 10:16 AM
  Subject: Re: Can't install ambari


  These are the prerequisites for a build. You are missing npm. 


    a.. JDK 1.6.0 
    b.. Apache Maven 3.0.5 <- Maven 3.1.0 results in errors when building ambari-agent

    c.. Python 2.6 
    d.. Python setuptools - python 2.6: Download or python 2.7: Download and run:
    2.6:

          sh setuptools-0.6c11-py2.6.egg 

    2.7

          sh setuptools-0.6c11-py2.7.egg 

    e.. rpmbuild (rpm-build package) 
    f.. g++ (gcc-c++ package) 
    g.. NodeJS - v0.10.2 or later is recommended.  Latest version tested for compatibility
is v0.10.24 (as of Jan 15, 2014).  Download the binary tarball, extract, and put the bin directory
in your PATH.  Verify that you can run the command node and npm.  Alternatively, you can use
yum to install NodeJS if you are on Fedora 18:

          #Fedora 18: sudo yum update audit; sudo yum --enablerepo=updates-testing install
nodejs npm 

    h.. Brunch 1.7.13 (to install it, run the following command after NodeJS is installed):

          npm install -g brunch@1.7.13 






  On Wed, Jun 25, 2014 at 8:09 PM, EdwardKing <zhangsc@neusoft.com> wrote:

    I want to install ambari1.4.3 under Redhat Linux 6.4,so I download ambari-1.4.3.tar.gz
and I use apache-maven-3.2.1 to execute following command:
    [root@localhost ambari-1.4.3]# tar xfvz ambari-1.4.3.tar.gz 
    [root@localhost ambari-1.4.3]# cd ambari-1.4.3
    [root@localhost ambari-1.4.3]# mvn versions:set -DnewVersion=1.4.3
    [root@localhost ambari-1.4.3]# mvn -B clean install package rpm:rpm -DnewVersion=1.4.3
-DskipTests -Dpython.ver="python >= 2.6"

    but it raise following errors:
    [ERROR] Failed to execute goal org.apache.maven.plugins:maven-antrun-plugin:1.7:run (compile)
on project ambari-web: An Ant BuildException has occured: Execute failed: java.io.IOException:
Cannot run program "npm" (in directory "/opt/yarn/ambari-1.4.3/ambari-web"): error=2, No such
file or directory
    [ERROR] around Ant part ...<exec dir="/opt/yarn/ambari-1.4.3/ambari-web" executable="npm"
failonerror="false">... @ 4:86 in /opt/yarn/ambari-1.4.3/ambari-web/target/antrun/build-ambari-web-compile.xml
    [ERROR] -> [Help 1]
    [ERROR] 
    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
    [ERROR] Re-run Maven using the -X switch to enable full debug logging.
    [ERROR] 
    [ERROR] For more information about the errors and possible solutions, please read the
following articles:
    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
    [ERROR] 
    [ERROR] After correcting the problems, you can resume the build with the command
    [ERROR]   mvn <goals> -rf :ambari-web
    [root@localhost ambari-1.4.3]#  

    Why raise above error? I try ambari-1.6.0 again,it still  raise above error. How can I
install ambari successfully? I am a newer to ambari,please help me. Thanks
    ---------------------------------------------------------------------------------------------------
    Confidentiality Notice: The information contained in this e-mail and any accompanying
attachment(s) 
    is intended only for the use of the intended recipient and may be confidential and/or
privileged of 
    Neusoft Corporation, its subsidiaries and/or its affiliates. If any reader of this communication
is 
    not the intended recipient, unauthorized use, forwarding, printing,  storing, disclosure
or copying 
    is strictly prohibited, and may be unlawful.If you have received this communication in
error,please 
    immediately notify the sender by return e-mail, and delete the original message and all
copies from 
    your system. Thank you. 
    ---------------------------------------------------------------------------------------------------


---------------------------------------------------------------------------------------------------
Confidentiality Notice: The information contained in this e-mail and any accompanying attachment(s)

is intended only for the use of the intended recipient and may be confidential and/or privileged
of 
Neusoft Corporation, its subsidiaries and/or its affiliates. If any reader of this communication
is 
not the intended recipient, unauthorized use, forwarding, printing,  storing, disclosure or
copying 
is strictly prohibited, and may be unlawful.If you have received this communication in error,please

immediately notify the sender by return e-mail, and delete the original message and all copies
from 
your system. Thank you. 
---------------------------------------------------------------------------------------------------
Mime
View raw message