ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yixiao Lin <yix...@yahoo-inc.com>
Subject Ambari service install/start errors
Date Thu, 26 Jun 2014 15:52:39 GMT
Hi all,

This is Yixiao from Yahoo. I am encountering some problems using the webUI to deploy/start
services.
I have configured my ambari(1.6.0) agents manually on RHEL 6, one server, three agents(including
one same host as server). I have deployed some basic Hadoop services: HDFS, YARN+MapReduce2,
teZ, Nagios and Zookeeper. However, now I am unable to start the History server of MapReduce2
or the Nodemanager of YARN. When I start them, they all run into the same error:
The error occurred when the script hit this command:
$ hadoop fs -mkdir
   Error: Could not find or load main class org.apache.hadoop.fs.FsShell

So I tried to run 
$ hadoop version
   Error: Could not find or load main class org.apache.hadoop.util.VersionInfo
$ echo $PATH
   /usr/kerberos/bin:/usr/lib64/qt-3.3/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/gs/java/jdk/bin:/home/gs/hadoop/current/bin:/home/gs/hbase/current/bin:/home/gs/pig/bin:/home/gs/pig/current/bin:/gridtools/generic/bin

$ echo $HADOOP_CLASSPATH

$ export HADOOP_CLASSPATH=/home/gs/hadoop/current/share/hadoop/common/hadoop-common-2.4.0.5.1406161905.jar
$ hadoop version
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory

It seems I don't have correct HADOOP_CLASSPATH configured

Does anyone know a possible solution to this?
When I installed the agents, what are the environment assumptions? I did this when I was installing
the agents, am I missing some steps?
$ cd /etc/yum.repos.d/
$ wget http://public-repo-1.hortonworks.com/ambari/centos6/1.x/updates/1.6.0/ambari.repo
$ yum install ambari-agent
 
Edit /etc/ambari-agent/conf/ambari-agent.ini

$ ambari-agent start

Thank you in advance,
Yixiao
Mime
View raw message