ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yusaku Sako <yus...@hortonworks.com>
Subject Re: Error accessing the ambari UI after a fresh install through vagrant recipe
Date Sat, 08 Feb 2014 01:33:44 GMT
I ran through the Quick Start Guide instructions to install both trunk
(1.5.0.3) and public (1.4.3.38) just now.
I did not run into any issues in either case and was able to login as
admin/admin and proceed to install.

One thing is that if you run different versions of Ambari Web and
hitting the same hostname (such as c6401.ambari.apache.org), you could
be running a different version of Ambari Web that you were testing
previously due to browser cache.  Please clear the browser cache and
try again and see if that fixes the problem.

If you are building from source, then it's a different issue.
One of the developers was having some weird Ambari Web issues
yesterday (though not the same symptom as described in the original
post).  It went away after he blew away "ambari-web/public",
"ambari-web/node_modules", and re-built Ambari Web via the mvn
command.
Sometimes, the node modules that the mvn build job fetches from the
public NPM repository causes breakage, even if the Ambari code did not
change at all.
Hope this helps.

Yusaku

On Fri, Feb 7, 2014 at 4:58 PM, Artem Ervits <are9004@nyp.org> wrote:
> Is there a way to access other bits other than trunk?
>
>
>
> From: Artem Ervits [mailto:are9004@nyp.org]
> Sent: Friday, February 07, 2014 9:59 AM
> To: user@ambari.apache.org
>
>
> Subject: Error accessing the ambari UI after a fresh install through vagrant
> recipe
>
>
>
> Hell all,
>
>
>
> I'm trying to follow the quick start guide at
> https://cwiki.apache.org/confluence/display/AMBARI/Quick+Start+Guide and
> using the Centos6.4 VM images. I started the Ambari server and browsed to
> http://c6401.ambari.apache.org:8080, I get a login page and I entered
> admin/admin. I receive the message "Error in retrieving web client state
> from ambari server". The install fetches the Ambari-server 1.4.3.38 bits,
> postgresql 8.4.18-1. The Ambari-server log gives no error message. Is there
> anything else I should check to debug this issue?
>
>
>
>
>
> Artem Ervits
>
> Artem@nyp.org
>
> New York Presbyterian Hospital
>
>
>
>
>
> ________________________________
>
>
> This electronic message is intended to be for the use only of the named
> recipient, and may contain information that is confidential or privileged.
> If you are not the intended recipient, you are hereby notified that any
> disclosure, copying, distribution or use of the contents of this message is
> strictly prohibited. If you have received this message in error or are not
> the named recipient, please notify us immediately by contacting the sender
> at the electronic mail address noted above, and delete and destroy all
> copies of this message. Thank you.
>
> This electronic message is intended to be for the use only of the named
> recipient, and may contain information that is confidential or privileged.
> If you are not the intended recipient, you are hereby notified that any
> disclosure, copying, distribution or use of the contents of this message is
> strictly prohibited. If you have received this message in error or are not
> the named recipient, please notify us immediately by contacting the sender
> at the electronic mail address noted above, and delete and destroy all
> copies of this message. Thank you.
>
> ________________________________
>
>
> Confidential Information subject to NYP's (and its affiliates') information
> management and security policies (http://infonet.nyp.org/QA/HospitalManual).
>
>
> ________________________________
>
> This electronic message is intended to be for the use only of the named
> recipient, and may contain information that is confidential or privileged.
> If you are not the intended recipient, you are hereby notified that any
> disclosure, copying, distribution or use of the contents of this message is
> strictly prohibited. If you have received this message in error or are not
> the named recipient, please notify us immediately by contacting the sender
> at the electronic mail address noted above, and delete and destroy all
> copies of this message. Thank you.
>
> This electronic message is intended to be for the use only of the named
> recipient, and may contain information that is confidential or privileged.
> If you are not the intended recipient, you are hereby notified that any
> disclosure, copying, distribution or use of the contents of this message is
> strictly prohibited. If you have received this message in error or are not
> the named recipient, please notify us immediately by contacting the sender
> at the electronic mail address noted above, and delete and destroy all
> copies of this message. Thank you.

-- 
CONFIDENTIALITY NOTICE
NOTICE: This message is intended for the use of the individual or entity to 
which it is addressed and may contain information that is confidential, 
privileged and exempt from disclosure under applicable law. If the reader 
of this message is not the intended recipient, you are hereby notified that 
any printing, copying, dissemination, distribution, disclosure or 
forwarding of this communication is strictly prohibited. If you have 
received this communication in error, please contact the sender immediately 
and delete it from your system. Thank You.

Mime
View raw message