ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Siddharth Wagle <swa...@hortonworks.com>
Subject Re: SSL Connect
Date Thu, 23 Jan 2014 17:53:19 GMT
Hi Roshan,

Seems like a problem with SSL handshake. What is the version of OS you are
on?
Also, can you check openssl and tls versions installed on the failing hosts.

Example:

[root@c6401 resources]# rpm -qa | grep openssl
openssl-devel-1.0.1e-16.el6_5.4.x86_64
openssl-1.0.1e-16.el6_5.4.x86_64

[root@c6401 resources]# rpm -qa | grep tls
gnutls-2.8.5-10.el6_4.2.x86_64

-Sid


On Thu, Jan 23, 2014 at 9:04 AM, Roshan Punnoose <roshanp@gmail.com> wrote:

> Some of my nodes are not able to connect to the ambari-server using HTTPS.
> I see timeouts that look like this:
>
> NetUtil.py:55 - Failed to connect to https://<host>:8440/cert/ca due to
> [Errno 8] _ssl.c:492: EOF occurred in violation of protocol
> NetUtil.py:74 - Server at https://<host>:8440 is not reachable, sleeping
> for 10 seconds...
>
> Any ideas? Maybe just the ability to turn off https for now?
>
> Roshan
>
>

-- 
CONFIDENTIALITY NOTICE
NOTICE: This message is intended for the use of the individual or entity to 
which it is addressed and may contain information that is confidential, 
privileged and exempt from disclosure under applicable law. If the reader 
of this message is not the intended recipient, you are hereby notified that 
any printing, copying, dissemination, distribution, disclosure or 
forwarding of this communication is strictly prohibited. If you have 
received this communication in error, please contact the sender immediately 
and delete it from your system. Thank You.

Mime
View raw message