ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michal Klempa (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-22839) Unable to set dfs.permissions.superusergroup using Ambari
Date Wed, 24 Jan 2018 13:11:00 GMT
Michal Klempa created AMBARI-22839:
--------------------------------------

             Summary: Unable to set dfs.permissions.superusergroup using Ambari
                 Key: AMBARI-22839
                 URL: https://issues.apache.org/jira/browse/AMBARI-22839
             Project: Ambari
          Issue Type: Bug
          Components: ambari-web
    Affects Versions: 2.6.0
         Environment: Ambari 2.6.0 with HDP 2.6.3
            Reporter: Michal Klempa


In Ambari UI, there is no dfs.permissions.superusergroup property, although it should be presented
in HDFS > Advanced hdfs-site section.

When trying to add this property using Custom hdfs-site, error stating the property already
exists is presented to user.

May have connection to https://issues.apache.org/jira/browse/AMBARI-22086

 

Steps to reproduce:
 # Install HDP 2.6.3 using Ambari 2.6.0 as described for example in this doc: [https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.0.0/bk_ambari-installation/content/ch_Getting_Ready.html]
 # Try to set dfs.permissions.superusergroup on service HDFS under Configs > Advanced,
should go into Advanced hdfs-site (or Custom hdfs-site).
 # result: property is not presented in UI in section Advanced hdfs-site nor it can be added
to Custom hdfs-site since the Add property dialog reports the property already exists

Expected behavior: Property should be present in Advanced hdfs-site in UI.

notes: property exists in configuration on disks: /etc/hadoop/conf/hdfs-site.xml contains
the key dfs.permissions.superusergroup, with default value of "hdfs".

 

This bug is also reported here: [https://community.hortonworks.com/questions/155952/how-to-modify-dfspermissionssuperusergroup-in-hdp.html]

And since in older versions it used to work, may it related to this fix: https://issues.apache.org/jira/browse/AMBARI-22086

 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message