ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wing Lam (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-22726) Test failing with no changes - BlueprintImplTest.testValidateConfigurations__hostGroupForNameNodeHAPositive
Date Tue, 16 Jan 2018 19:34:00 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-22726?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Wing Lam updated AMBARI-22726:
------------------------------
    Description: 
When I run just the test testValidateConfigurations__hostGroupForNameNodeHAPositive in an
IDE, the test fails.
 It appears that the problem is that the configuration for the BlueprintValidatorImpl is not
set up in testValidateConfigurations_hostGroupForNameNodeHAPositive_._ Instead, some other
tests setup some configuration for the testValidateConfigurations_hostGroupForNameNodeHAPositive
test.

Changes that fix this can be seen here:
 [https://github.com/ReedOei/ambari/commit/09b7dc3f5660325ee0c8010ff4e1d46ca027289c]

  was:
When I run just the test testValidateConfigurations__hostGroupForNameNodeHAPositive, the test
fails.
It appears the problem is that the configuration for the BlueprintValidatorImpl is not set
up in testValidateConfigurations__hostGroupForNameNodeHAPositive. It appears that other tests
setup some configuration for testValidateConfigurations__hostGroupForNameNodeHAPositive.

Changes that fix this can be seen here:
https://github.com/ReedOei/ambari/commit/09b7dc3f5660325ee0c8010ff4e1d46ca027289c


> Test failing with no changes  - BlueprintImplTest.testValidateConfigurations__hostGroupForNameNodeHAPositive
> ------------------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-22726
>                 URL: https://issues.apache.org/jira/browse/AMBARI-22726
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: trunk
>         Environment: Ubuntu, 16.04 LTS
>            Reporter: Wing Lam
>            Priority: Minor
>             Fix For: trunk
>
>
> When I run just the test testValidateConfigurations__hostGroupForNameNodeHAPositive in
an IDE, the test fails.
>  It appears that the problem is that the configuration for the BlueprintValidatorImpl
is not set up in testValidateConfigurations_hostGroupForNameNodeHAPositive_._ Instead, some
other tests setup some configuration for the testValidateConfigurations_hostGroupForNameNodeHAPositive
test.
> Changes that fix this can be seen here:
>  [https://github.com/ReedOei/ambari/commit/09b7dc3f5660325ee0c8010ff4e1d46ca027289c]



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message