ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tobias Hofer (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-22658) Cannot write krbPasswordExpiry in FreeIPA
Date Fri, 15 Dec 2017 15:43:00 GMT
Tobias Hofer created AMBARI-22658:
-------------------------------------

             Summary: Cannot write krbPasswordExpiry in FreeIPA
                 Key: AMBARI-22658
                 URL: https://issues.apache.org/jira/browse/AMBARI-22658
             Project: Ambari
          Issue Type: Bug
          Components: ambari-server
    Affects Versions: 2.6.0
         Environment: Ubuntu 16.04 LTS with FreeIPA 4.3.1
            Reporter: Tobias Hofer


Ambari Server fails to change the krbPasswordExpiry date because of an invalid date format.

IPA fails to update the user by IPAKerberosOperationHandler.
{code:java}
user-mod %s --setattr krbPasswordExpiration=%s
{code}

The used format
{noformat}
yyyyMMddHHmmss.SSS'Z'
{noformat}

needs to be
{noformat}
yyyyMMddHHmmss'Z'
{noformat}

at least for the FreeIPA version distributed with Ubuntu 16.04.

It would be great if Ambari is going to support FreeIPA 4.3.1 as well.




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message