ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Levas (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (AMBARI-22629) Disabling Kerberos after enabled during Blueprint install fails with missing data directory error
Date Wed, 13 Dec 2017 17:10:00 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-22629?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Levas reassigned AMBARI-22629:
-------------------------------------

    Assignee: Eugene Chekanskiy  (was: Robert Levas)

> Disabling Kerberos after enabled during Blueprint install fails with missing data directory
error
> -------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-22629
>                 URL: https://issues.apache.org/jira/browse/AMBARI-22629
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.6.0
>            Reporter: Robert Levas
>            Assignee: Eugene Chekanskiy
>              Labels: blueprints, kerberos
>             Fix For: 2.6.2
>
>         Attachments: blueprint_single_node_zk.json, cluster_template_single_node_zk.json,
screenshot-error-dialog.png
>
>
> Disabling Kerberos after enabled during Blueprint install fails with missing data directory
error:
> {noformat}
> The data directory has not been set.  Generated data can not be stored.
> {noformat}
> !screenshot-error-dialog.png!
> This is caused by an invalid security state set for the installed components since the
appropriate state is not set while enabling Kerberos during the installation process:
> {noformat}
> ambari=> select * from hostcomponentstate;
>  id | cluster_id |  component_name  |   version    | current_state | host_id | service_name
| upgrade_state | security_state
> ----+------------+------------------+--------------+---------------+---------+--------------+---------------+----------------
>   1 |          2 | KERBEROS_CLIENT  | UNKNOWN      | INSTALLED     |       1 | KERBEROS
    | NONE          | UNSECURED
>   2 |          2 | ZOOKEEPER_CLIENT | 2.5.0.0-1245 | INSTALLED     |       1 | ZOOKEEPER
   | NONE          | UNSECURED
>   3 |          2 | ZOOKEEPER_SERVER | 2.5.0.0-1245 | STARTED       |       1 | ZOOKEEPER
   | NONE          | UNSECURED
> {noformat}
> The expected state for each component is {{SECURED}}, not {{UNSECURED}}. Because of this,
Ambari _thinks_ there is no work to be done, causing this issue. 
> *Steps to reproduce*:
> # Setup Ambari, ensure KDC is installed on some host and Kerberos client libs are installed
on the Ambari server host with the krb5.conf setup properly
> # Install Blueprint - [^blueprint_single_node_zk.json]
> # Create clister - [^cluster_template_single_node_zk.json]
> # When cluster is created, Kerberos should be enabled and all services up
> # Disable Kerberos - error occurs during Unkerberize Cluster task.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message