ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Hurley (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-22545) Tie MapReduce to Hive and Tez For Patch Upgrades
Date Wed, 29 Nov 2017 14:52:01 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-22545?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jonathan Hurley updated AMBARI-22545:
-------------------------------------
    Attachment: AMBARI-22545.patch

> Tie MapReduce to Hive and Tez For Patch Upgrades
> ------------------------------------------------
>
>                 Key: AMBARI-22545
>                 URL: https://issues.apache.org/jira/browse/AMBARI-22545
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: 2.6.0
>            Reporter: Jonathan Hurley
>            Assignee: Jonathan Hurley
>            Priority: Blocker
>             Fix For: 2.6.1
>
>         Attachments: AMBARI-22545.patch
>
>
> Hive is currently unable to upgrade without MapReduce since the property {{mapreduce.admin.user.env}}
cannot properly be detected from {{mapred-site}}. 
> STR:
> - Install a base cluster at 2.6.3.0 with ZK, HDFS, YARN, MapR, Tez, Hive
> - Push YARN/Tez forward to 2.6.3.1-1
> - Push Hive forward to 2.6.3.2-1
> - Push MapR forward to 2.6.3.3-1
> When you run a Hive query against Tez, it was failing. The fix was to add the following
to {{tez-site}} since it wasn't detected on {{mapred-site}}:
> {code}
> mapreduce.admin.user.env=LD_LIBRARY=./tezlib/lib/native
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message