ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-22541) Oozie stop failed during IOP migration with missing module get_lzo_packages
Date Wed, 29 Nov 2017 14:45:02 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-22541?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16270857#comment-16270857
] 

Hudson commented on AMBARI-22541:
---------------------------------

FAILURE: Integrated in Jenkins build Ambari-branch-2.6 #498 (See [https://builds.apache.org/job/Ambari-branch-2.6/498/])
AMBARI-22541. Oozie stop failed during IOP migration with missing module (aonishuk: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=4ebfc7c5232c2d42eb989a988946316353cd616d])
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/OOZIE/package/scripts/oozie.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/OOZIE/package/scripts/params_linux.py


> Oozie stop failed during IOP migration with missing module get_lzo_packages
> ---------------------------------------------------------------------------
>
>                 Key: AMBARI-22541
>                 URL: https://issues.apache.org/jira/browse/AMBARI-22541
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Andrew Onischuk
>            Assignee: Andrew Onischuk
>             Fix For: 2.6.1
>
>         Attachments: AMBARI-22541.patch
>
>
> **STR**
>   1. Deployed cluster with Ambari version: 2.4.2.0_IBM_000000 and HDP version: 4.2.5.0-0000
(LZO is enabled in HDFS configs)
>   2. Upgrade Ambari to Target Version: 2.6.1.0-64 | Hash: cd4db8e9ac0ea7ce14fc1253959a121688f34952
>   3. Register HDP-2.6.4.0-51 version and call remove iop-slect
>   4. Install the bits and start EU
> **Result**  
> EU failed at Stop Oozie server
>     
>     
>     
>     Traceback (most recent call last):
>       File "/var/lib/ambari-agent/cache/stacks/BigInsights/4.2.5/services/OOZIE/package/scripts/oozie_server.py",
line 148, in <module>
>         OozieServer().execute()
>       File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 367, in execute
>         method(env)
>       File "/var/lib/ambari-agent/cache/stacks/BigInsights/4.2.5/services/OOZIE/package/scripts/oozie_server.py",
line 84, in stop
>         import params
>       File "/var/lib/ambari-agent/cache/stacks/BigInsights/4.2.5/services/OOZIE/package/scripts/params.py",
line 28, in <module>
>         from params_linux import *
>       File "/var/lib/ambari-agent/cache/stacks/BigInsights/4.2.5/services/OOZIE/package/scripts/params_linux.py",
line 33, in <module>
>         from resource_management.libraries.functions.get_lzo_packages import get_lzo_packages
>     ImportError: No module named get_lzo_packages
>     
> Live cluster: <http://172.22.87.3:8080/#/main/admin/stack/upgrade>



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message