ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doroszlai, Attila (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-22516) Ambari 2.6 build has python 2.6 dependency
Date Mon, 27 Nov 2017 21:58:00 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-22516?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Doroszlai, Attila updated AMBARI-22516:
---------------------------------------
    Attachment: AMBARI-22516.branch-2.6.patch

> Ambari 2.6 build has python 2.6 dependency
> ------------------------------------------
>
>                 Key: AMBARI-22516
>                 URL: https://issues.apache.org/jira/browse/AMBARI-22516
>             Project: Ambari
>          Issue Type: Improvement
>         Environment: RHEL 7.4
>            Reporter: Ronald van de Kuil
>            Priority: Critical
>         Attachments: AMBARI-22516.branch-2.6.patch
>
>
> The installation guide for Ambari 2.6 instructs us to build the RHEL rpm using:
> mvn -B clean install package rpm:rpm -DnewVersion=2.6.0.0.0 -DskipTests -Dpython.ver="python
>= 2.6"
> I just tried this on RHEL 7 (which is not listed in the instructions) and then the build
fails:
> /usr/lib/rpm/brp-python-bytecompile: line 44: /usr/bin/python2.6: No such file or directory
> I read that downgrading RHEL 7 to use python 2.6 is not a good idea because allegedly
several OS scripts depend on it.
> I saw a different JIRA issue that gave some suggestions to overwrite the required version
using commandline options.
> Should ambari be able to run on the version 7 of the OS at this moment? .And if so, should
it work fine with the 2.7 version of python?



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message