ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-22467) YARN, MapReduce2, Hive, and Oozie Should Conditionally Install LZO
Date Fri, 17 Nov 2017 14:40:00 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-22467?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Onischuk updated AMBARI-22467:
-------------------------------------
    Attachment: AMBARI-22467.patch

> YARN, MapReduce2, Hive, and Oozie Should Conditionally Install LZO
> ------------------------------------------------------------------
>
>                 Key: AMBARI-22467
>                 URL: https://issues.apache.org/jira/browse/AMBARI-22467
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Andrew Onischuk
>            Assignee: Andrew Onischuk
>             Fix For: 2.6.1
>
>         Attachments: AMBARI-22467.patch
>
>
> Changes Summary:
> - Do not install lzo if GPL license if not accepted, instead give out logger.warning
and skip
> - Remove installation of lzo from metainfo.xml. Since we need to install lzo on restart
if lzo is enabled/license accepted, we still need to do this in Python code. No need to duplicate.
> Clients will also use that code during install.
> - Move function get_lzo_packages to lzo_utils.py
> - Add code for Yarn, MR2, Hive to install lzo, edit existing code to install lzo for
HDFS,Oozie to use lzo_utils.py 
> Notes:
> - Impl is Patch Upgrade friendly as uses the same code to detect {stack_version} as all
the other packages. That code (not implemented here) gets version depending component specific
repo info not stack specific.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message