ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Hurley (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-22386) Patch Upgrades Broken For Clients Due To Versioned LD Library
Date Wed, 08 Nov 2017 21:05:00 GMT
Jonathan Hurley created AMBARI-22386:
----------------------------------------

             Summary: Patch Upgrades Broken For Clients Due To Versioned LD Library
                 Key: AMBARI-22386
                 URL: https://issues.apache.org/jira/browse/AMBARI-22386
             Project: Ambari
          Issue Type: Bug
    Affects Versions: 2.6.0
            Reporter: Jonathan Hurley
            Assignee: Jonathan Hurley
            Priority: Blocker
             Fix For: 2.6.1


When services are patched to different versions, jobs being run in containers are unable to
pickup the correct JARs from the {{LD_LIBRARY_PATH}} passed in via the job. 

Consider the following situation:
- Base cluster installed at 2.6.3.0-1
- Enable some sort of codec, like snappy
- YARN patched to 2.6.3.1-1
- Hive patched to 2.6.3.2-1

When Hive goes to run jobs on Tez or when jobs are run on MapR, whatever is sending the job
is resolving the {{hdp.version}} to its own version. The box that the job runs on, however,
might not have that specific versioned directory. 

The problem can only be solved externally by providing a way to ensure that the native libraries
are on every machine which could potentially run jobs. We could install bits on every host,
but that would defeat the space-saving purposes of patch upgrades.

Another solution is to ensure that the Tez and MapR tarballs have the required libraries and
that those libraries are added to the classpath of launched jobs.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message