ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-22312) Downgrade From HDP 2.6 to 2.5 Leaves 2.6 Hosts as CURRENT Instead of INSTALLED
Date Thu, 26 Oct 2017 18:15:01 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-22312?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16220940#comment-16220940
] 

Hadoop QA commented on AMBARI-22312:
------------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12894058/AMBARI-22312.patch
  against trunk revision .

    {color:red}-1 patch{color}.  The patch command could not apply the patch.

Console output: https://builds.apache.org/job/Ambari-trunk-test-patch/12566//console

This message is automatically generated.

> Downgrade From HDP 2.6 to 2.5 Leaves 2.6 Hosts as CURRENT Instead of INSTALLED
> ------------------------------------------------------------------------------
>
>                 Key: AMBARI-22312
>                 URL: https://issues.apache.org/jira/browse/AMBARI-22312
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: 2.6.0
>            Reporter: Jonathan Hurley
>            Assignee: Jonathan Hurley
>            Priority: Blocker
>             Fix For: 2.6.1
>
>         Attachments: AMBARI-22312.patch
>
>
> STR:
> - Install HDP 2.5.4 with ZK
> - Perform an RU to 2.6.0.0
> - Downgrade back to 2.5.4
> All hosts remain current after finalization:
> {code}
> {
>   "href": "http://localhost:8080/api/v1/clusters/c1/stack_versions?fields=ClusterStackVersions/host_states",
>   "items": [
>     {
>       "href": "http://localhost:8080/api/v1/clusters/c1/stack_versions/1",
>       "ClusterStackVersions": {
>         "cluster_name": "c1",
>         "id": 1,
>         "repository_version": 1,
>         "stack": "HDP",
>         "version": "2.5",
>         "host_states": {
>           "CURRENT": [
>             "c6403.ambari.apache.org",
>             "c6402.ambari.apache.org",
>             "c6401.ambari.apache.org"
>           ],
>           "INSTALLED": [],
>           "INSTALLING": [],
>           "INSTALL_FAILED": [],
>           "NOT_REQUIRED": [],
>           "OUT_OF_SYNC": []
>         }
>       }
>     },
>     {
>       "href": "http://localhost:8080/api/v1/clusters/c1/stack_versions/2",
>       "ClusterStackVersions": {
>         "cluster_name": "c1",
>         "id": 2,
>         "repository_version": 2,
>         "stack": "HDP",
>         "version": "2.6",
>         "host_states": {
>           "CURRENT": [
>             "c6403.ambari.apache.org",
>             "c6402.ambari.apache.org",
>             "c6401.ambari.apache.org"
>           ],
>           "INSTALLED": [],
>           "INSTALLING": [],
>           "INSTALL_FAILED": [],
>           "NOT_REQUIRED": [],
>           "OUT_OF_SYNC": []
>         }
>       }
>     }
>   ]
> }
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message