ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nishant Bangarwa (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-22221) Druid Components install fails with AttributeError: 'DruidBroker' object has no attribute 'available_packages_in_repos'
Date Thu, 12 Oct 2017 15:52:00 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-22221?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nishant Bangarwa updated AMBARI-22221:
--------------------------------------
    Attachment: AMBARI-22221.patch

> Druid Components install fails with AttributeError: 'DruidBroker' object has no attribute
'available_packages_in_repos'
> -----------------------------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-22221
>                 URL: https://issues.apache.org/jira/browse/AMBARI-22221
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.6.0
>            Reporter: Dileep Kumar Chiguruvada
>            Assignee: Nishant Bangarwa
>            Priority: Blocker
>             Fix For: 2.6.0
>
>         Attachments: AMBARI-22221.patch
>
>
> Druid Components install fails with AttributeError: 'DruidBroker' object has no attribute
'available_packages_in_repos'.
> {code}
> Traceback (most recent call last):
>   File "/var/lib/ambari-agent/cache/common-services/DRUID/0.10.1/package/scripts/broker.py",
line 28, in <module>
>     DruidBroker().execute()
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 367, in execute
>     method(env)
>   File "/var/lib/ambari-agent/cache/common-services/DRUID/0.10.1/package/scripts/druid_node.py",
line 38, in install
>     self.install_packages(env)
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 793, in install_packages
>     name = self.format_package_name(package['name'])
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 535, in format_package_name
>     self.load_available_packages()
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 756, in load_available_packages
>     if self.available_packages_in_repos:
> AttributeError: 'DruidBroker' object has no attribute 'available_packages_in_repos'
> {code}
> This issue is due to Ambari trying to install indivifual "Druid Componennt" package which
is not part of repo, Druid has single  druid-[version].noarch.rpm.
> Seems there is change in Ambari deploy code to search for each component that exist and
trying to install the package with component name.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message